vCenter Client fails to display Symantec ApplicationHA Tab and Dashboard but shows "Navigation to the Webpage was canceled" or "There is a problem with this website's security certificate."

Article:TECH200692  |  Created: 2012-12-10  |  Updated: 2014-02-18  |  Article URL http://www.symantec.com/docs/TECH200692
Article Type
Technical Solution

Product(s)

Issue



Symantec ApplicationHA tab and the Symantec ApplicationHA Dashboard may fail to display the application status. Instead the Tab would look like this:

vCenter Screenshot

Or:

 

This would typically happen after applying a Microsoft security advisory patch KB2661254 on the system. 


Error



Navigation to the Webpage was canceled or There is a problem with this website's security certificate.


Environment



Application HA 6.0

Symantec HA 6.0.1


Cause



This issue occurs due to the difference in the key length of the authentication certificate issued by ApplicationHA Console Server and the key length desired by Microsoft Windows.

Older browsers accepted the 512 bits certificate. However, the newer browsers now require a certificate of minimum 1024 bits.

Microsoft security advisory patch KB2661254 is applied to the system.


Solution



Close the vSphere Client and perform the following steps on the Symantec High Availability Console Server: 

  1. Navigate to the following path:
    C:\Program Files\Veritas\ApplicationHA\tomcat\conf
  2. Using a text editor tool, open the server.xml file and search for the string "KeystorePass".
    The “KeystorePass” represents the Keystore Password.
  3. Note down the password mentioned.
  4. Using the command prompt navigate to the following path:
    C:\Program Files\Veritas\ApplicationHA\JRE\bin
  5. Execute the keytool.exe and provide the following argument using the password in step3:

keytool.exe -genkey -alias tomcat -keyalg RSA -validity 3650 -keypass <password> -keystore .keystore -storepass <password> -dname CN="Symantec ApplicationHA Console",O=Symantec,L=MountainView,S=CA,C=US -keysize 2048

  1. Navigate to the following location:
    C:\Program Files\Veritas\ApplicationHA\JRE\bin
  2. Copy the ".keystore" file.
  3. From services.msc stop the Symantec ApplicationHA Service.
  4. Navigate to the following path, take a back up of the existing “.keystore” and replace the ".keystore"   file  with the one copied in step 7.
     C:\Program Files\Veritas\ApplicationHA\Tomcat\cert

Note: Do not rename the ".keystore" when you save the backup copy. You must save it using the same name.

  1. Start the Symantec ApplicationHA Service.
  2. Re-launch the vSphere Client. 



Article URL http://www.symantec.com/docs/TECH200692


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