"Encryption Key Not Found" appears when selecting a backup set on tape in the "Where do you want to restore the data from?" screen.

Article:TECH200810  |  Created: 2012-12-13  |  Updated: 2012-12-13  |  Article URL http://www.symantec.com/docs/TECH200810
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Article Type
Technical Solution


Problem



An attempt to restore from a backup set originally taken to a Backup to Disk (B2D) location and duplicated to a tape drive using hardware encryption returns "Encryption Key Not Found" when selecting the backup set on tape.  A prompt appears asking the user to create a new encryption key, but a key has already been created, and used for the duplicate to tape.


Error



Encryption Key Not Found

Cannot find an encryption key on this Backup Exec server for the selected backup set.  To continue the operation, you must create an encryption key for this Backup Exec server, and it must use the same pass phrase as the original key.

Do you want to create a new encryption key for this Backup Exec server now?


Environment



This issue occurs when a backup set that was originally backed up to Backup to Disk folder using no encryption key is duplicated to a tape drive or library using hardware encryption.


Cause



Backup Exec catalogs do not return the correct encryption key hash.  This can be seen in a debug of the Backup Exec Management service using SGMon:

MANAGEME: [12/10/12 10:50:49] [0000]     ERROR: LocalizedException:
MANAGEME: [12/10/12 10:50:49] [0000]     ERROR:   Message: One or more of the
encryption keys required by this job could not be retrieved. Verify the job
settings to ensure that there is a valid encryption key for this job.
MANAGEME: [12/10/12 10:50:49] [0000]
MANAGEME: [12/10/12 10:50:49] [0000]     ERROR:   Reason: One or more of the
encryption keys required by this job could not be retrieved. Verify the job
settings to ensure that there is a valid encryption key for this job.
MANAGEME: [12/10/12 10:50:49] [0000]
MANAGEME: [12/10/12 10:50:49] [0000]     ERROR:   Stack:    at
BackupExec.Management.Components.Security.SecurityManager.GetByHash
(DataEncryptionKey& dek, UInt32 nHashMatchingCriteria, Byte[] Hash, UInt32
HashLen, UInt32 HashAlgo)
MANAGEME: [12/10/12 10:50:49] [0000]        at SyncInvokeGetByHash(Object ,
Object[] , Object[] )
MANAGEME: [12/10/12 10:50:49] [0000]        at
System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object
[] inputs, Object[]& outputs)
MANAGEME: [12/10/12 10:50:49] [0000]        at
System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc&
rpc)
MANAGEME: [12/10/12 10:50:49] [0000]        at
System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5
(MessageRpc& rpc)
MANAGEME: [12/10/12 10:50:49] [0000]        at
System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

 


Solution



Workaround:

This issue affects duplicate jobs that utilize hardware encryption.  Using software encryption locates the correct key and allows the restore to proceed from tape.

 -------
 
Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.
 
This issue is currently under investigation by Symantec Corporation. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns.  For information on how to contact Symantec Sales, please see  http://www.symantec.com

Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.


Supplemental Materials

SourceETrack
Value3023405
Description

EXCH: "Encryption Key Not Found" during restore selection from of non-encrypted B2D set duplicated to tape with hardware encryption enabled.



Article URL http://www.symantec.com/docs/TECH200810


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