Duplicate Job never runs after the backup completes in a CASO environment

Article:TECH200921  |  Created: 2012-12-17  |  Updated: 2013-11-18  |  Article URL http://www.symantec.com/docs/TECH200921
Article Type
Technical Solution


Issue



In a CASO environment a backup job runs, but the duplicate job that is supposed to follow it does not run.  It doesn't go scheduled or hang, it just never runs.


Error



JobManager:GenerateSetCopyScriptFromHistory: Could not locate catalog entry for FamilyGuid

 

Cause



 

The selection list for the duplicate job is created right at the end of the backup job.  In cases where the catalog/job history operation takes a long time near the end of the backup operation, this process of creating the duplicate job starts before the job history has been finalized.  This results in the duplicate job never getting created because it is unable to create the selections that need to be duplicated.  Since the job never gets created properly, it never runs, and doesn't generate a job history either. 

If debugging is enabled for BESERVER when the backup job completes, the following line shows up in the resulting SGMon log.

JobManager:GenerateSetCopyScriptFromHistory: Could not locate catalog entry for FamilyGuid

 


Solution



A hotfix is now available for this issue in the current version(s) of the product(s) mentioned in this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.

 

Backup Exec 2012 Rev 1798 Service Pack 3 (TECH205351).

 

 

 


Supplemental Materials

SourceETrack
Value2866555
Description

CASO: Duplicate jobs randomly do not run




Article URL http://www.symantec.com/docs/TECH200921


Terms of use for this information are found in Legal Notices