Symantec iOSCommand Service Fails To Start

Article:TECH200978  |  Created: 2012-12-18  |  Updated: 2013-09-09  |  Article URL http://www.symantec.com/docs/TECH200978
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Article Type
Technical Solution


Issue



Right-click Device Management actions, such as lock are not available for enrolled iOS devices.

Device Management actions, such as lock or inventory, do not reach the device.

The Symantec iOSCommandService is not started.


Error



The System Event log reports the following error:

Event 7009 - A timeout was reached (30000 milliseconds) while waiting for the Symantec iOS Command Service service to connect.

Event 7000 - The Symantec iOS Command Service service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.


Environment



Windows 2008 R2, SP1

Symantec Mobile Management 7.2 SP1, 7.2 SP2.1

Mobile Management Server 7.2.4940.0, 7.2.5724.0


Cause



This issue is still under investigation.


Solution



As a workaround, you can do the following steps to help the Symantec iOS Command Service start/restart.

On the Mobile Management Site-server,

  1. Open the "services.msc" or Services management console.
  2. Select the "Symantec iOS Command Service", right-click and select properties.
  3. Change the startup type to "Automatic (Delayed Start)".
  4. Click "OK".
  5. Open the registry editor - run regedit.exe. ** Always take precautions and backup your registry before modifying.**
  6. Navigate to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control".
  7. Create a new DWORD.
  8. Set the name to "ServicesPipeTimeout" and value (decimal) to "60000". (1 minute)
  9. Close registry editor and reboot the Mobile Management Site-server.
  10. Once the server has rebooted, open the services.msc, or Services management console.
  11. After a few minutes, verify that the Symantec iOS Command Service has started.


Supplemental Materials

SourceETrack
Value3013298


Article URL http://www.symantec.com/docs/TECH200978


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