Notification email for quarantine cannot be sent to recipient from Symantec Messaging Gateway (SMG) .

Article:TECH201158  |  Created: 2012-12-25  |  Updated: 2013-02-06  |  Article URL http://www.symantec.com/docs/TECH201158
Article Type
Technical Solution


Issue



SMG with LDAP integrated cannot send notification to recipient when incoming emails are quarantined.


Error



Brightmaillog.log:

[BrightmailScheduler_Worker-0] ERROR - Cannot notify the user that he or she has new spam messages.
com.symantec.smg.controlcenter.BrightmailException: Could not connect to SMTP host: mail2.abc.com, port: 25 ; nested exception is:
  javax.mail.MessagingException: Could not connect to SMTP host: mail2.abc.com, port: 25;
  nested exception is:
 java.net.SocketTimeoutException: connect timed out
 at com.symantec.smg.controlcenter.internal.mail.transport.MailSend.sendNotificationMessage(MailSend.java:251)
 at com.symantec.smg.controlcenter.quarantine.spam.SpamNotificationManager.sendNotification(SpamNotificationManager.java:247)
 at com.symantec.smg.controlcenter.quarantine.spam.SpamNotificationManager.access$000(SpamNotificationManager.java:79)
 at com.symantec.smg.controlcenter.quarantine.spam.SpamNotificationManager$1.process(SpamNotificationManager.java:156)
 at com.symantec.smg.controlcenter.quarantine.spam.SpamNotificationManager$1.process(SpamNotificationManager.java:153)
 at com.symantec.smg.controlcenter.quarantine.QuarantineDAOMySQL.processNewSpam(QuarantineDAOMySQL.java:775)
 at com.symantec.smg.controlcenter.quarantine.spam.SpamNotificationManager.notification(SpamNotificationManager.java:151)
 at com.symantec.smg.controlcenter.quarantine.spam.SpamNotificationTask.executeTask(SpamNotificationTask.java:112)
 at com.symantec.smg.controlcenter.internal.scheduledtask.ScheduledTask.execute(ScheduledTask.java:133)
 at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
 at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: javax.mail.MessagingException: Could not connect to SMTP host: mail2.abc.com, port: 25;
  nested exception is:
 java.net.SocketTimeoutException: connect timed out
 at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1545)
 at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:453)
 at javax.mail.Service.connect(Service.java:291)
 at javax.mail.Service.connect(Service.java:172)
 at javax.mail.Service.connect(Service.java:121)
 at com.symantec.smg.controlcenter.internal.mail.transport.TransportFactory.createTransport(TransportFactory.java:202)
 at com.symantec.smg.controlcenter.internal.mail.transport.MailTransportMxLookup.sendMessage(MailTransportMxLookup.java:111)
 at com.symantec.smg.controlcenter.internal.mail.transport.MailSend.sendNotificationMessage(MailSend.java:246)
 ... 10 more
Caused by: java.net.SocketTimeoutException: connect timed out
 at java.net.PlainSocketImpl.socketConnect(Native Method)
 at java.net.PlainSocketImpl.doConnect(Unknown Source)
 at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
 at java.net.PlainSocketImpl.connect(Unknown Source)
 at java.net.SocksSocketImpl.connect(Unknown Source)
 at java.net.Socket.connect(Unknown Source)
 at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:265)
 at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:227)
 at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1511)
 ... 17 more


Environment



AD server was integrated to SMG successfully. Authentication was enabled in DDS.  Local domain was added into SMG correctly.


Cause



There're several servers in mx records for recipient's domain name. One of them(mail2.abc.com) was configured not to receive incoming email. By default, SMG sends quarantine notification to the recipient mail server based on the DNS query result. But the result points to the mail server (mail2.abc.com) which does not receive email. 


Solution



1. Logon SMG web console

2. Click Administration-->Control Center -->SMTP

3. Choose Define new host, type the IP address of correct recipient mail server and the SMTP port (25), Save

4. Use Putty or other SSH tools to logon SMG command line as account admin

5. Input command " service restart controlcenter" to restart controlcenter service.

6. Notification email can be sent to recipient successful




Article URL http://www.symantec.com/docs/TECH201158


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