Applying Legal Holds takes unacceptably long periods.

Article:TECH201364  |  Created: 2013-01-04  |  Updated: 2013-01-16  |  Article URL http://www.symantec.com/docs/TECH201364
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Article Type
Technical Solution


Issue



Applying Legal Holds can take longer than expected.


Environment



- Symantec Enterprise Vault  (EV) 9.0 SP3 (9.0.3)

- Symantec Enterprise Vault Discovery Accelerator (DA)  9.0 SP3 (9.0.3) 


Cause



Several factors can be involved to slow the Legal Hold processing.  Possible contributing factors are, but not limited to:

  1. Any Vault Store database running out of HoldIdentity values.
  2. Any Enterprise Vault Storage Service server having a hung StorageOnlineOpns process.
  3. The Legal Hold Integrity Check processing finding hold count mismatches between the DA Customer database and any Vault Store database.
  4. The Legal Hold processing repeatedly attempting to process the same batch of items to be placed on hold.

 


Solution



1. For the issue of a Vault Store database running out of HoldIdentity values, this issue has been fixed in DA 10.0 SP2 (10.0.2), a hotfix to DA 9.0 SP3 (9.0.3), and a Cumulative Hotfix (CHF) to DA 9.0 SP4 (9.0.4).  Implement any of the following solutions for DA 9.0.3 or greater:

  1. For EV and DA 9.0 SP3, apply the hotfix in TECH190697, referenced in the Related Articles section below.
  2. Upgrade to EV and DA 9.0 SP4 and apply Cumulative Hotfix 1 (9.0.4CHF1 - see TECH199014 in the Related Articles section below) or 9.0.4CHF2 (See TECH200520 in the Related Articles section below) to all EV and DA servers in the site.
  3. Upgrade DA then EV to 10.0 SP2 and Cumulative Hotfix1 (10.0.2CHF1) or later (See TECH200022 in the Related Articles section below for 10.0.2CHF1) to all EV and DA servers in the site.

2. For the issue of a hung StorageOnlineOpns process, the process must be manually ended using Task Manager, then the Enterprise Vault Accelerator Manager Service (EVAMS) on the DA server must be restarted.

   To determine if a StorageOnlineOpns process is hung, complete the following steps:

  1. Using the Vault Service Account (VSA) for Enterprise Vault, log onto the Enterprise Vault server that is running the EV Storage Service for the Vault Store containing the items to be placed on hold.
  2. Launch the Services application.
  3. Locate and stop the Enterprise Vault Storage Service or stop all Enterprise Vault services (i.e., stop the Enterprise Vault Admin Service and select the pop-up option to stop all associated services).
  4. After the EV Storage Service has stopped, launch Task Manager.
  5. Sort the contents of the Processes tab by process name.
  6. Look for any instance of StorageOnlineOpns.exe that is still running.  If any instance of this process is found to still be running, that process is hung.
  7. To stop any hung StorageOnlineOpns.exe. process:
    1. Single click on the process
    2. Click the End Process button in the lower right of the Task Manager display.
    3. Confirm the request to end the process.

3. For the issue of the Legal Hold Integrity Check processing finding hold count mismatches, contact Symantec Enterprise Vault Technical Support for assistance.

4. Certain conditions can exist to cause the legal hold processing to continuously retry the same batch of items to be placed on hold.  Possible reasons for legal hold processing to loop on the same batch can be cause by, but not limited to:

  1. A Vault Store database running out of HoldIdentity values.
  2. Partial implementation of the hotfix in TECH190697 to increase the number of available HoldIdentity values.

    Note that Cumulative Hotfix 2 for DA 9.0 SP4 (9.0.4CHF2) adds a feature to automatically retry failed holds except for items determined to no longer be in the Vault Store.  This feature includes an error event thrown into the Symantec Enterprise Vault Event Log, every 12 hours by default, when items exist that cannot be placed on hold after repeated attempts.  Look for Event ID 562 errors to confirm any failed hold looping issue.

     This looping does not stop until the cause of the looping is found and resolved or worked around.  Contact Symantec Enterprise Vault Technical Support for assistance determining the cause and resolution or workaround for this legal hold looping issue.

 


Supplemental Materials

SourceETrack
Value2827236
Description

DA: Applying Legal Holds takes unacceptably long periods.




Article URL http://www.symantec.com/docs/TECH201364


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