Slow analytics performance when enabling a case in DA.

Article:TECH201365  |  Created: 2013-01-04  |  Updated: 2014-04-03  |  Article URL http://www.symantec.com/docs/TECH201365
Article Type
Technical Solution

Product(s)

Issue



When enabling a Case in Enterprise Vault (EV) Discovery Accelerator (DA) for Analytics, the captured data within the Case is very slow to complete the Analytics processing.

 


Environment



- Symantec Enterprise Vault Discovery Accelerator 8.0 or greater

- Microsoft SQL Server 2005 or 2008 R2

 


Cause



The Analytics processing takes the KVSSavesetID for each captured item within the DA Case and retrieves a copy of the item from storage.  Each item is then analyzed to record the data required for the fields in the Analytics related tables in the DA Customer database.

This processing typically begins quickly, but slows as more items are added to the Analytics related tables.  This slowdown can relate to Analytics processing at a rate of about 1/10th of that for DA Cases with small numbers of items.

The processing is impacted by high disk input / output (I/O) usage between the SQL Server and its disk storage.  Having the DA customer database file and its associated transaction log file (or files) on the same physical or logical drive causes the disk I/O to require significantly higher throughput as may be available.

 


Solution



There are two current options to resolve this issue:

  1. Break down the millions of hits into smaller amounts in across multiple DA cases (less than 1 million items per case recommended).
  2. Separate the CA customer database file and its transaction log file (or files) to separate physical or logical disk drives with different spindles for each drive.

The following actions could provide workarounds to reduce the impact on the processing rate of having large numbers of items within a DA Case.

  1. Perform SQL database maintenance on the DA Customer database more frequently than normal while the items are working trough the Analytics processing.  See TECH74666 in the Related Articles section below for the Symantec recommended database maintenance actions.  The specific maintenance activities that would have the greatest impact are:
    1. Backup and truncate the transaction log.
    2. Rebuild the table indexes.
    3. Update the statistics.
  2. Keep the amount of data within a DA Case limited to 5000 items or less.  The fewer items to process through Analytics, the better the performance will be.
  3. Enable Analytics on a DA Case while only a few items have been captured, then add additional items through more searches, allowing each search's items to process through before running or accepting the next search.

 

 

 

 


Supplemental Materials

SourceETrack
Value2931190
Description

Analytics processing of very large Cases is 90% slower than the processing of small Cases.




Article URL http://www.symantec.com/docs/TECH201365


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