"Unknown Policy Error" When Attempting to Apply a Policy to a SCSP Agent

Article:TECH201404  |  Created: 2013-01-07  |  Updated: 2013-11-18  |  Article URL http://www.symantec.com/docs/TECH201404
Article Type
Technical Solution


Issue



When attempting to apply a policy to a Symantec Critical System Protection (SCSP) Windows Agent, a "Unknown Policy Error" is thrown. 


Error



"Unknown Policy Error" in SCSP console.

Enabling Trace Debugging (sisipsconfig -trace) from the command line offers more detail on the error.  Specifically, "Error running Translator 128" is shown in the Trace Debug logs in the \Agent\scsplog\SISIPSService.log

The "128" refers to a Windows error.

In another case, the error "-1073741502" was seen in the trace debug logs.  This translates to 0xC0000142 = 'DLL Initialization failed', which is another symptom of Desktop Heap Space running low.  

For NT-Windows 2003, a Microsoft Tool called Dheapmon can be used to monitor Desktop Heap Space. See http://www.microsoft.com/en-us/download/details.aspx?id=17782 for more information.

In Windows 2008, the desktop heap space is dynamically assigned.

To learn more about Desktop Heap Space, see http://blogs.msdn.com/b/ntdebugging/archive/2007/01/04/desktop-heap-overview.aspx.


Cause



This is caused by a Desktop Heap Space Issue.  The offending machine had run out of desktop heap space and was unable to launch a process.


Solution



See the following Microsoft Articles on this issue:

Original 2006 article applying to Windows NT:
http://support.microsoft.com/kb/156484

Explanation of the issue as applies to Win XP, Win 2003
http://support.microsoft.com/default.aspx?scid=kb;en-us;184802

For some ways to address the issue:
http://support.microsoft.com/kb/126962





Article URL http://www.symantec.com/docs/TECH201404


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