Backup Exec 2012 Database Maintenance fails on Audit Logs

Article:TECH201551  |  Created: 2013-01-10  |  Updated: 2013-03-06  |  Article URL http://www.symantec.com/docs/TECH201551
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Article Type
Technical Solution

Product(s)

Problem



When the Backup Exec Database Maintenance occurs at (4 AM) and alert is generated that the maintenance has failed.   The Database Maintenance grooms job history, alerts, audit log information, and other items out of the Backup Exec database according to the setting under "Configuration and Settings - Backup Exec Settings - Database Maintenance".

 

 

 

 


Error



Database Maintenance Failure
(Server: "SERVERNAME") (Job: "Database Maintenance") Summary of database maintenance activity:

* Performed database consistency check for BEDB database
* Saved contents of BEDB database
* Optimized BEDB database size from 2500.38 MB to 2167.06 MB
* Deleted expired data for BEDB database:
     0 empty legacy backup-to-disk folders were deleted
     0 expired reports were deleted
     1216 expired job histories were deleted
     229 expired alert histories were deleted
     0 expired job logs were deleted

Maintenance has failed: -536837662, -536837662: :: -2147217871:Query timeout expired


 


Environment



Backup Exec 2012

 

 


Cause



Application Log

Log Name:      Application
Source:        Backup Exec
Event ID:      57348
Task Category: None
Level:         Error
Keywords:      Classic
Description:
Backup Exec Alert: Database Maintenance Failure
(Server: "HONSHU") (Job: "Database Maintenance") Summary of database maintenance activity:

* Performed database consistency check for BEDB database
* Saved contents of BEDB database
* Optimized BEDB database size from 4610.38 MB to 2167.06 MB
* Deleted expired data for BEDB database:
     0 empty legacy backup-to-disk folders were deleted
     0 expired reports were deleted
     1216 expired job histories were deleted
     229 expired alert histories were deleted
     0 expired job logs were deleted

Maintenance has failed: -536837662, -536837662: :: -2147217871:Query timeout expired
Total elapsed time: 00:05:55


Log Name:      Application
Source:        Backup Exec
Event ID:      57345
Task Category: (65535)
Level:         Information
Keywords:      Classic
Description:
Database Exception Context:Age/Purge Audit Log Error:-536837662: :: -2147217871:Query timeout expired :: DB Error Set 0: native=0xffffffff source=Microsoft OLE DB Provider for SQL Server hr=0x80040e31 Query timeout expired


Log Name:      Application
Source:        Backup Exec
Event ID:      57345
Task Category: (65535)
Level:         Information
Keywords:      Classic
Description:
Current DbTimeoutValue=30


Log Name:      Application
Source:        Backup Exec
Event ID:      57345
Task Category: (65535)
Level:         Information
Keywords:      Classic
Description:
Database Exception Context:m_QueryTimeoutInSeconds=30 sql=SELECT [ParentID],[ObjectID],[OperationID],[TimeStamp],[UserName],[Message]  FROM  [DBO].[BELog] a1  WHERE [TimeStamp]<=? Error:-536837662: :: -2147217871:Query timeout expired :: DB Error Set 0: native=0xffffffff source=Microsoft OLE DB Provider for SQL Server hr=0x80040e31 Query timeout expired
 

 

 


Solution



 

There is no workaround available at this time, but the database maintenance failure should not affect the ability of the program to perform normal backup, restore, and other operations.

 

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned in this article. Symantec Corporation is committed to product quality and satisfied customers.
 
This issue is currently under investigation by Symantec Corporation. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns.  For information on how to contact Symantec Sales, please see 
http://www.symantec.com Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.
 

NOTE: Customers experiencing this issue are encouraged to contact Symantec Technical Support as data is still being collected to assist in resolving this issue.

 

 


Supplemental Materials

SourceETrack
Value3047529
Description

Backup Exec 2012 Database Maintenance fails on Audit Log table.



Article URL http://www.symantec.com/docs/TECH201551


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