KNOWN ISSUE: Report "All Resources Picker Report" used by advanced resource pickers within Asset (like the Software Product picker on the Software License Edit page) is slow because of string localization
| Article:TECH201631 | | | Created: 2013-01-14 | | | Updated: 2013-02-14 | | | Article URL http://www.symantec.com/docs/TECH201631 |
| NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made. |
Problem
Customer noticed that the software picker within the Software License, Edits are too slow to use. Profiler trace reported 22 seconds just to open the Software Product picker on that page.
Reproduction Steps:
1. Create a new Software License
2. On the Software License edit page, click the link to select the associated software products.
3. Make sure the picker is in advanced mode. Default report in advanced is the "All Resources Picker Report"
Actual Result:
In customers environment this page took 22 seconds to load
Environment
Symantec Management Platform 7.1 SP2, 7.1 SP2 MP1
Cause
Known Issue. The issue comes down to the query used by the "All Resources Picker Report" which is the default report that the picker uses and no picker report specifically for Software Products.
Also, the issue lies with how the service account was initially configured. The user’s domain name was typed in FQDN\Username form rather than Domain\Username, which is subsequently stored in the registry as such. The impersonation code reads this from the registry and then compares the domain\name pair with a .NET security api (WindowsIdentity.GetCurrent().Name) domain\name string, if they don’t match, then the CollectionMembershipCache stops working. This .NET api is returning the underlying NETBIOS domain name.
This is an edge case, most customers do not type in their domain\name as FQDN\UserName. If they do, this is simple to work around by resetting the account using the AeXConfig.exe utility. See HOWTO10009 "How to change the Application Identity in NS7"
Solution
This issue has been reported to Symantec Development team. Enhancements to this issue has been provided with the ITMS 7.1 SP2 MP1 Rollup v3. See HOWTO81832
|
|
| Source | ETrack |
| Value | 3041690 |
Article URL http://www.symantec.com/docs/TECH201631
Terms of use for this information are found in Legal Notices









Thank you.