"License adding error" when trying to apply a license

Article:TECH202080  |  Created: 2013-01-25  |  Updated: 2013-08-13  |  Article URL http://www.symantec.com/docs/TECH202080
Article Type
Technical Solution

Product(s)

Issue



When attempting to apply a license to an on-premise Symantec App Center, the following error occurs.

  


Error



User interface:

License adding error

Server returned error: General error

 

appstore.log:

 

timestamp=2013-01-24 22:08:25.664,logname=aclog,level=ERROR,module=licwrapper,function=AddLicense,line=267,
tenant=[tenant_name],username=[user_name],sessionid=eaea202795b569b991d0d0bb5a2b6f16,
url=/appstore/webapi2/license/save,msgid=,Licensing error (SLICWrapper.AddLicense) code=1, err=General error

timestamp=2013-01-24 22:08:25.664,logname=aclog,level=ERROR,module=licensing,function=__AddLicenseInternal,line=484,
tenant=[tenant_name],username=[user_name],sessionid=eaea202795b569b991d0d0bb5a2b6f16,
url=/appstore/webapi2/license/save,
msgid=,__AddLicenseInternal(serial_number=[serial_number]) failed for tenant=[tenant_name], err=1 (General error)

  

 


Environment



  • Symantec App Center 4.x

  


Cause



This error may occur if DNS is not configured properly on the server, or internet access is not available.

 


Solution



When a license is installed in App Center, it must communicate with the Symantec Licensing servers to register the serial number. Ensure internet access is available for the server, and that DNS is functioning properly.

  

View a video about Licensing your Symantec App Center.

 

 


Supplemental Materials

SourceETrack
Value3064000
Description

Generic error when adding license if Symantec licensing servers are unavailable



Article URL http://www.symantec.com/docs/TECH202080


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