Server Initiatied Oracle restore fail with an error "RMAN-06172: no AUTOBACKUP found or specified handle is not a valid copy or piece"
| Article:TECH202207 | | | Created: 2013-01-30 | | | Updated: 2013-01-30 | | | Article URL http://www.symantec.com/docs/TECH202207 |
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Problem
Server Initiatied Oracle restore fail with an error
"RMAN-06172: no AUTOBACKUP found or specified handle is not a valid copy or piece"
DBA intiatied Control file restore or Archive Log restore also fail and report the error
CDbsbOra::processMessage: ORA-19511: Error received from media manager layer, error text:
CDbsbOra::processMessage: BEError(0xe0001501) The specified backup object wasnot found in Backup Exec catalogs.
Error
SGMON on media server shows the following output
BECAT: [11/21/12 16:50:59] [4504] SQL connection: 221eb60 select * from ControlInfo
BECAT: [11/21/12 16:50:59] [4504] Input Parameters for VxBSARestore_View : [1] (BE_1fnqshvd_1_1),[4](ServerName::\\Servername.Domain.com\Instance),[5]
(0),[2](1800),[3](1800)
BECAT: [11/21/12 16:50:59] [4504] SELECT * FROM CatVxBSARestore_View WHERE PieceId LIKE 'BE[_]1fnqshvd[_]1[_]1' AND ResourceName = 'ServerName::\\Servername.Domain.com\Instance' AND CreateTime >= 1800 AND CreateTime <= 1800 ORDER BY CreateTime DESC, ImageNumber, PieceId, FragmentNumber
BECAT: [11/21/12 16:50:59] [4504] SQL connection: 221eb60 SELECT * FROM CatVxBSARestore_View WHERE PieceId LIKE 'BE[_]1fnqshvd[_]1[_]1' AND ResourceName = 'ServerName::\\Servername.Domain.com\Instance' AND CreateTime >= ? AND CreateTime <= ? ORDER BY CreateTime DESC, ImageNumber, PieceId, FragmentNumber
BECAT: [11/21/12 16:50:59] [4504] result(0) numRetry(300)
BECAT: [11/21/12 16:50:59] [4504] Number of records returned: 0
BECAT: [11/21/12 16:50:59] [4504] m_sqlqueryTTL( 0 )
BECAT: [11/21/12 16:50:59] [4504] return 100
BECAT: [11/21/12 16:50:59] [4504] out : CAT_BSET_NOT_FOUND
Environment
This issue is presently seen with Oracle installed on Linux (RHEL) servers.
Cause
This issue occurs if the Oracle Server Time Zone is set to MYT, SGT. This issue may also occur with other Time Zone. If the Time Zone set on your server is not the one mentioned here then please confirm the debug log output to verify if the issue is same.
Solution
Workaround:
Change the Linux Server Time Zone to GMT and run the restore.
Note:- Please apply the above workaround only if you are performing a Redirect Restore of Oracle data to a different Server. If you are restoring Archive Logs from RMAN on the same server (Production Server) which was backed up or restoring Control file to the same server please check with Oracle support if the Linux system Time Zone can be changed.
Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.
This issue is currently under investigation by Symantec Corporation. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns. For information on how to contact Symantec Sales, please see http://www.symantec.com Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.
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| Source | ETrack |
| Value | 2995598 |
| Description | ORCL:Restore oracle database failed with error 0xE0001501 - specified backup object was not found in Backup Exec Catalogs. |
Article URL http://www.symantec.com/docs/TECH202207
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