db2admin user password has expired when using SSH to login to SSIM 4.8
| Article:TECH202494 | | | Created: 2013-02-05 | | | Updated: 2013-05-09 | | | Article URL http://www.symantec.com/docs/TECH202494 |
Problem
When you try to login to SSIM 4.8 using SSH you get an error that the db2admin password has expired and please create new one. However when you do that the SSH session closes.
Cause
You have installed SSIM more than 90 days ago and you have not applied patch 1. The Linux users passwords will expire. You will have 7 days grace period to be able to change this using an SSH session. After that you will have to use a remote access card that allows root access or by accessing a console physically attached to the SSIM.
Solution
If you are able to login as db2admin and you have not applied Patch 1 then login as db2admin and su - to root user and type the following commands to unlock db2admin and set it to not expire:
chage -m -1 db2admin
Then type:
passwd -u db2admin
You will need to access the SSIM via a remote access connection, ssh session, or by accessing a console physically attached to the SSIM to unlock all accounts and then disable the password expiration policy for the Linux users in SSIM.
Login as root and type the following commands pressing enter after each command:
passwd -u db2admin
passwd -u ldapdb2
passwd -u idsldap
passwd -u dasusr1
passwd -u symcmgmt
passwd -u simuser
passwd -u monitor
passwd -u sopr
passwd -u sadm
chage -M -1 db2admin
chage -M -1 ldapdb2
chage -M -1 idsldap
chage -M -1 dasusr1
chage -M -1 symcmgmt
chage -M -1 simuser
chage -M -1 monitor
chage -M -1 sopr
chage -M -1 sadm
Then you will need to su - to root and install Patch 1.
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Article URL http://www.symantec.com/docs/TECH202494
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