KNOWN ISSUE: The Symantec Management Agent occasionally fails to send up notification of program execution events

Article:TECH203439  |  Created: 2013-03-01  |  Updated: 2013-07-18  |  Article URL http://www.symantec.com/docs/TECH203439
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Article Type
Technical Solution


Issue



When a software delivery task executes a program the agent should generate a notification of the event up to the NS. Occasionally after a program has executed the SMA fails to send the event. As a result the record of executing the program is never logged to the "Inv_AeX_SWD_Execution_Summary" table.  The absence of these events causes the reports relying on data in this table to be inaccurate.


Environment



SMP 7.1 SP2 MP1


Cause



This is a known issue that has been present for many versions of the SMA.  The agent begins generating the notification event but deletes it before it is sent. The event notification pretty much evaporates before it can be posted via PostEvent.aspx.


Solution



This issue was reported to Symantec Development team and a fix will be provided in SMP 7.1 SP2 MP1 Rollup v4.

Currently there is a point-fix that can be applied on top of SMP 7.1 SP2 MP1 Rollup v3.  See attached file called "Pointfix_eTrack3061292_7.1_SP2_MP1_v3_Agent.zip" .


A new agent has been provided for this fix:
Agent version 7.1.15426.8426


HOW TO INSTALL THIS POINTFIX

1.     Extract files from the archive to the NS hard drive.
2.     Make sure PointFix is extracted not to Altiris install directory (or any subfolder to it)!!!
3.     Execute PFInstaller.exe under user with administrative privileges.
4.    Accept UAC (User Account Control) prompt, select Install Files. Old SMA will be automatically backuped to the Backup folder at the same location where PFinstaller is and replaced with the new one. Log-file Log.txt will be created at the same location where PFinstaller is.
5.    Use Symantec Management Agent upgrade policy to update SMA agent. Clone or re-schedule Symantec Management Agent upgrade policy, if it was already used once.

 

 

HOW TO UNINSTALL

1.  Make sure that Backup subfolder is located in PFinstaller’ directory
2.  Execute PFInstaller.exe under user with administrative privileges.
3.  Accept UAC (User Account Control) prompt, select Uninstall Files.

 

 


Supplemental Materials

SourceETrack
Value3061292


Article URL http://www.symantec.com/docs/TECH203439


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