In some circumstances attachment properties were not indexed in environments that contain legacy data

Article:TECH203789  |  Created: 2013-03-12  |  Updated: 2013-08-01  |  Article URL http://www.symantec.com/docs/TECH203789
Article Type
Technical Solution


Issue



Symantec Corporation has identified an issue with a storage component of Enterprise Vault called StorageCrawler.exe, where attachment properties for items archived by Enterprise Vault 8.0 and later may not be indexed correctly and therefore not searchable. Compliance Accelerator and Discovery Accelerator searches may not return messages where only the attachments would have met the search criteria if run against affected indexes.

This issue only occurs if the following three conditions all apply:

1. Enterprise Vault has been upgraded from version 2007 or earlier to Enterprise Vault 10.0.2 or 10.0.3.

2. Savesets from versions of Enterprise Vault 2007 or earlier, and savesets from Enterprise Vault 8.0 and later, are both present in the environment.

3. While on 10.0.2 or 10.0.3 version, the same Storage Crawler instance processed both types of savesets simultaneously during index operations. (During a rebuild or upgrade of a 32-bit index to 64-bit index or a rebuild of a 64-bit index that was previously a 32-bit index containing legacy savesets).

 
Exceptions: What is NOT affected:
The following scenarios are not affected by this issue:
 
  • If Enterprise Vault 2007 or earlier has never been installed you are not affected by this issue.
  • If Enterprise Vault 10.0.2 or 10.0.3 have never been installed you are not affected by this issue.
  • If Enterprise Vault 10.0.0 or 10.0.1 is installed you are not affected. 

Environments running Enterprise Vault 10.0.2 or later and have upgraded from Enterprise Vault 2007 or earlier installation, but have not upgraded or rebuilt any indexes containing savesets from versions of Enterprise Vault 2007 or earlier, are not affected.

What is affected:
The following server versions of Symantec Enterprise Vault are affected: 
 
  • Enterprise Vault for Microsoft Exchange 10.0.2, Build 1112
  • Enterprise Vault for Microsoft Exchange 10.0.3, Build 1090
  • Enterprise Vault for File System Archiving 10.0.2, Build 1112
  • Enterprise Vault for File System Archiving 10.0.3, Build 1090
  • Enterprise Vault for Lotus Domino 10.0.2, Build 1112
  • Enterprise Vault for Lotus Domino 10.0.3, Build 1090
  • Enterprise Vault for Microsoft SharePoint 10.0.2, Build 1112
  • Enterprise Vault for Microsoft SharePoint 10.0.3, Build 1090
  • Enterprise Vault for SMTP 10.0.2, Build 1112
  • Enterprise Vault for SMTP 10.0.3, Build 1090

Cause



With Enterprise Vault 2007 or earlier installations, the indexable data on an item and its attachments used to be stored at the time of archiving within the actual saveset itself. Beginning with Enterprise Vault 8.0 this was changed and the indexable data is no longer embedded in the saveset, but is generated on demand. StorageCrawler.exe is the process responsible for generating the indexable data for the purpose of indexing. It is possible that StorageCrawler.exe could process the indexable data of Enterprise Vault 2007 or earlier item, and then in the same process, processes the indexable data of an Enterprise Vault 8.0 or later item.  This would result in the latter items’ attachment properties not being generated and therefore not being indexed.

NOTE: Attachment properties include subject, date and content.


How to determine if affected:
Please refer to TECH203995 for further details on how to run the tool.


Solution



This issue is formally resolved in the Enterprise Vault 10.0.3 Cumulative Hotfix 2, Enterprise Vault 10.0.2 Hotfix, and Enterprise Vault 10.0.2 Cumulative Hotfix 2 and the Hotfix for this issue as listed below.

If Running Enterprise Vault 10.0.2
NOTE: Do not upgrade or rebuild any indexes while on 10.0.2 until you have performed step 1 below.  Remove any rebuild or upgrade tasks that may be pending.

1. Apply following hotfix: http://www.symantec.com/docs/TECH204377
2. Rebuild any indexes that are suspected of being affected by this issue.

If Running Enterprise Vault 10.0.2 with Cumulative Hotfix 2:
NOTE: Do not upgrade or rebuild any indexes while on 10.0.2 until you have performed step 1 below.  Remove any rebuild or upgrade tasks that may be pending.

1. Apply following hotfix: http://www.symantec.com/docs/TECH204441
2. Rebuild any indexes that are suspected of being affected by this issue.

If Running Enterprise Vault 10.0.3
NOTE: Do not upgrade or rebuild any indexes while on 10.0.3 until you have performed step 1 below. Remove any rebuild or upgrade tasks that may be pending.

1. Enterprise Vault 10.0.3 Cumulative Hotfix 2 Release: http://www.symantec.com/docs/TECH205731
2. Rebuild any indexes that are suspected of being affected by this issue.
 

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1. Always perform a FULL backup prior to and after any changes to your environment.
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Supplemental Materials

SourceETrack
Value3011655
Description

Attachment content may not be indexed in certain circumstances when indexes with legacy data are being upgraded




Article URL http://www.symantec.com/docs/TECH203789


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