Encrypted Messages sent by Symantec Mobile Encryption for iOS Cannot be Decrypted by the PGP Support Package for BlackBerry

Article:TECH203926  |  Created: 2013-03-15  |  Updated: 2013-05-15  |  Article URL http://www.symantec.com/docs/TECH203926
Article Type
Technical Solution


Issue



Encrypted messages sent using the Symantec Mobile Encryption for iOS app prior to release 2.0.2.7 cannot be decrypted by the PGP Support Package for BlackBerry.  The BlackBerry user sees only the cipher text.


Environment



Mobile Encryption for iOS is supported by Symantec Encryption Management Server version 3.3 or above.

PGP Partitioned Format is being used by Mobile Encryption for iOS.

The default Apple mail client is being used. 


Cause



The Apple mail client adds additional white space to the encrypted text generated by the Symantec Mobile Encryption for iOS app.  This additional white space causes the PGP Support Package for BlackBerry to fail to process the encrypted text correctly.

Note that if Google Sync is used as the mail transport provider on the iOS device, this problem does not occur.  Google Sync is now end of life for new users but it was designed to allow access to Gmail, Google Calendar, and Contacts via the Microsoft Exchange ActiveSync protocol.


Solution



Upgrade to Symantec Mobile Encryption for iOS release 2.0.2.7 released on 2013-05-14 available from the App Store in iTunes or on your IOS device.


Supplemental Materials

SourceETrack
Value3111892



Article URL http://www.symantec.com/docs/TECH203926


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