Found the filter is no longer present on the 'Windows Patch Remediation Settings' policy.
| Article:TECH204204 | | | Created: 2013-03-22 | | | Updated: 2013-04-02 | | | Article URL http://www.symantec.com/docs/TECH204204 |
Problem
Followed process detailed on KM: HOWTO79488; however, the targeted custom filter for the 'Windows Patch Remediation Settings' policy is being removed.
Environment
Patch Management 7.1 SP1, SP2 & MP1.
Cause
Found the clean up process clears the custom filter from the policy if it is not 'accessed' within 7 days. This is to prevent target membership bloating within the Symantec_CMDB database.
Solution
This issue is currently being reviewed by Symantec Inc. and will be resolved in a future release of Patch Management.
Please work through the following to resolve immediately:
- Open the Microsoft SQL Server Management Studio logged on with Application Identity (Symantec Service Account) credentials
- Confirm recent database backup succeeded
- Preventive maintenance as with best practice before updating anything in the database
- Rename the default Stored Procedure
- Open Object Explorer > Databases > Symantec_CMDB > Programmability > Stored Procedures
- Find Stored Procedure: spGetResourceTargetsToPurge
- Rename Stored Procedure
- Sufficient rename example: spGetResourceTargetsToPurge_old
- Run the SQL script in the attached text doc to recreate the Stored Procedure with needed modification
- Execute against the Symantec_CMDB database
- Confirm recent database backup succeeded
This work around will exclude the 'Windows Patch Remediation Settings' policy from the automated clean up process.
Attachments
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Article URL http://www.symantec.com/docs/TECH204204
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