OpsCenter NetBackup Data Collection appears to hang and Java.exe process consumes allocated memory.

Article:TECH205951  |  Created: 2013-05-07  |  Updated: 2013-07-01  |  Article URL http://www.symantec.com/docs/TECH205951
Article Type
Technical Solution


Issue



NetBackup Data collection appears to hang, preventing additional data collection cycles. 


Error



None.  Java.exe (OpsCenter Server) consumes all memory heap allocated.

See the Related Article linked below for information on how to determine how OpsCenter Server is processing memory allocation, and how to make adjustments.


Environment



OpsCenter Server 7.5.0.5
Windows Server 2003 R2 x 64


Cause



This issue was observed in an OpsCenter environment where millions of image fragments exist on disk.  A recursive SQL query was loading all Image fragments into memory.


Solution



The formal resolution for this issue (Etrack 3104267) is included in the following release:

  •  NetBackup OpsCenter 7.5 Maintenance Release 6 (7.5.0.6)

NetBackup 7.5.0.6 is now available - please access the Related Article below for more information.

Workaround:
Please contact Symantec technical support, referencing this document ID and Etrack 3103018 to obtain an update for OpsCenter 7.5.0.5 that changes the affecting SQL query to prevent "out of memory" issues.


Supplemental Materials

SourceETrack
Value3104267
Description

Image Collector eventually stops and Console becomes unresponsive




Article URL http://www.symantec.com/docs/TECH205951


Terms of use for this information are found in Legal Notices