The Enterprise Vault service is not available.

Article:TECH206012  |  Created: 2013-05-08  |  Updated: 2013-10-04  |  Article URL http://www.symantec.com/docs/TECH206012
Article Type
Technical Solution


Issue



Windows may block the contents of Enterprise Vault hotfixes downloaded from the internet.

 

Consider the following scenario:

  The latest cumulative hotfix for Enterprise Vault (EV) is downloaded from the support website using Internet Explorer.    Typically these hotfixes consist of multiple files compressed as a .zip file.  Windows blocks the .zip because it is downloaded from the Internet Zone and is saved with a Zone.Identifier alternate data stream.  When the .zip is extracted, all of the files are subsequently marked as blocked as well.   The blocked files are then copied to one or more EV servers.   Depending on which files are included in the cumulative hotfix, for example if it includes KVS.EnterpriseVault.Runtime.dll, this issue may be seen.

Fig 1. - blocked file
 

  Users attempting to use any of the web applications like search.asp may receive the message: The Enterprise Vault service is not available.  Users of Archive Explorer may receive error: XML returned for tree view is not as expected (500).   The problem may appear intermittently.


Error



The Enterprise Vault service is not available.

XML returned for tree view is not as expected (500)


Cause



If no W3WP process is active (such as upon server restart or idle timeout,) the first user to make a request to the EV web app will cause IIS to initialize the application.  If the first user is an end-user with no admin rights on the EV server, windows will prevent the blocked files from loading and executing.  If the first user to make a request to the EV web app is a local administrator on the EV server, the webapp will initilalize successfully despite the files being blocked.


Solution



Unblock all affected files on each EV server and restart IIS (iisreset). On EV 10.0 and higher restarting IIS may fail the EV indexing service and cause cluster failover so the EV indexing service would need to be stopped or taken offline first and then restarted after IIS is restarted.

Files can be unblocked by clicking the unblock button that is seen on the screenshot above.   To unblock multiple files at one, the streams.exe utiltity from Microsoft may be used.  Streams.exe can be downloaded here.

To unblock all files in the Enterprise Vault installation directory with steams.exe, a command similar to the following could be used on each EV server (the installation path may vary) :

streams -s -d "c:\Program Files (x86)\Enterprise Vault"

In the future the problem can be avoided by making sure the .zip file is unblocked before extracting its contents and copying to the EV servers.

 

Note: This issue can also occur if ASP.NET 2.0 is not enabled or properly registered on the particular virtual directory. Refer to TECH208491 in the related articles section





Article URL http://www.symantec.com/docs/TECH206012


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