After installing Agent for Linux, an error 'Failed to open device: /dev/symbdsnapctl, errno: 2' is added in the /var/log/messages.

Article:TECH209535  |  Created: 2013-08-11  |  Updated: 2014-11-19  |  Article URL http://www.symantec.com/docs/TECH209535
Article Type
Technical Solution


Issue



After installing Agent for Linux, an error 'Failed to open device: /dev/symbdsnapctl, errno: 2' is added in the /var/log/messages.


Error



'SYMBDSNAP_SDK[XXXX]: Failed to open device: /dev/symbdsnapctl, errno: 2'


Environment



Backup Exec 2012 Agent for Linux
Red Hat Enterprise Linux (RHEL) 6.x


Cause



Advanced Open File Option for Linux (AOFO-L) is not supported for the use with the kernel version. (For details, please see NOTE below.)

NOTE:
"SymBDSnap" in messages is a driver name for AOFO-L.
The requisite to enable AOFO-L depends on the kernel versions rather than Linux OS versions.

Please refer to the following URL for the kernel version corresponding for each Red Hat release version, since the available kernel versions are not described in Software Compatibility List (SCL) for Backup Exec.
https://access.redhat.com/site/articles/3078

For instance:
Software Compatibility List (SCL) for Backup Exec 2012 says that AOFO-L is supported for the use with Red Hat 6 Update 1. Red Hat says that the kernel version for Red Hat 6 Update 1 is 2.6.32-131.0.15.
AOFO-L is supported for the use with 2.6.32-131.0.15 as a consequence. If the kernel version is 2.6.32-220 or later, AOFO-L is not supported as of 12 August 2013.

 


Solution



This message can be ignored. Backups without using AOFO-L are performed.


 





Article URL http://www.symantec.com/docs/TECH209535


Terms of use for this information are found in Legal Notices