KNOWN ISSUE: DS7.5 - Reboot-To and Prepare for image capture task fails.

Article:TECH212019  |  Created: 2013-10-29  |  Updated: 2013-11-11  |  Article URL http://www.symantec.com/docs/TECH212019
Article Type
Technical Solution


Issue



 If you assign a Reboot-To task or a Prepare for Image capture task to a client, the client restarts, but goes back to the same / previous environment instead of the targeted environment.

This is different from a similar error we're tracking where the reboot never starts.  In this scenario, the reboot happens, but once reaching PXE, goes to the incorrect destination (e.g. production instead of automation).


Cause



There are multiple potential causes, and a few we're not sure of:

  1. The main cause is a faulty Stored Procedure that gives the PXE server a resopnse to the request when PXE booting.
  2. Another cause has been NOT enabling the appropriate Respond To options in the NBS General settings, so the system is ignored.  This is also only PXE related

Solution



 The resolution depends on the cause, of course!

  1. There is a new stored procedure attached below that will help with the first issue.  NOTE:  This is probably good for anyone to have and will be in the next HG, so you may as well get it!
  2. Be sure to go, in the console, to Settings | Deployment | NBS General Settings, and enable the appropriate respond to options.  There's respond to predefined (may not be necessary), respond to New Computers (initial deployment) and respond to managed computers.  The latter is the one most likely missing.  Enable it, set it for a time out of more than 1 second update the inventory so the NS knows, and it should work.  If not, be SURE the config file received the menu change on the site/PXE server under "Program Files\Altiris\Altiris Agent\Agents\Deployment\SBS\SBSConfiguration.XML.

 

Additional Troubleshooting

For troubleshooting you might want to verify what Responce SMP will provide back to PXE Services by opening this URL:

http://NSSERVER/altiris/Deployment/Services/GetPXEBootInfo.aspx?xml=<request><GetPXEBootInfo><UniqueID></UniqueID><MacAddress>11-11-11-11-11-11</MacAddress><SerialNumber></SerialNumber><IPAddress></IPAddress></GetPXEBootInfo></request>

 

Replace NSSERVER with your server name.

Replace MacAddress - with MAC of Client machine you're performing testing with.

 

Other values can be also provided, you can obtain those either from computer information or from SbsLog_Pxe.txt (if you have NBS Logging enabled on level 255)

This might be used in scenarios where we getting malformed response from SMP or if you suspect that PXE is not performing correctly.

 

NOTE:

 

If You would try with Unknown MAC - then result should be client="2"


Attachments

Execute query against Symantec CMDB
getspdeployment_getpxebootinfo.txt (4 kBytes)


Article URL http://www.symantec.com/docs/TECH212019


Terms of use for this information are found in Legal Notices