After upgrading to the latest 7.5 Hotfix and scheduling a task clients immediately fail with Unable to get a .NET type error message

Article:TECH212593  |  Created: 2013-11-19  |  Updated: 2014-04-15  |  Article URL http://www.symantec.com/docs/TECH212593
Article Type
Technical Solution


Issue



After scheduling a task clients immediately fail with Unable to get a .NET type error message


Error



An unknown exception was thrown.
 
System.Exception: SerializedParameterCollection::ToValue(): Unable to get a .NET type named Altiris.TaskManagement.Common.Tokens.TokenDefinitionCollection, Altiris.TaskManagement.Common, Version=7.5.XXXX.XX (Latest Version), Culture=neutral, PublicKeyToken=99b1e4cc0d03f223 at Altiris.DotNetLib.Collections.SerializedParameterCollection.ToParameterValueCollection() at Altiris.ClientTask.Server.Data.ClientTaskServerExecutionInstance.get_InputParameterValues() at Altiris.ClientTask.Server.Execution.ClientTaskEngineExecutionThread.LoadInputParametersFromTaskInstanceParent() at Altiris.ClientTask.Server.Execution.ClientTaskEngineExecutionThread.Execute() at Altiris.TaskManagement.Common.Execution.Engine.TaskExecutionEngine.ProcessTaskExecuteOperation(TaskInstanceRequest request, TaskEngineExecutionThread thread)


Environment



After upgrade to latest HF for NS 7.5, where the Task Server service has not been upgraded yet.  Altiris Agent has usually been upgraded on the Task Server.

Result is that the Task Server is running the latest Altiris Agent but not the latest version of Task Server.


Cause



This error will come up when attempting to execute tasks on already upgraded client that registered to not yet upgraded Task Server” (i.e. client version > than Task Server version)

The agent software package within the Policy has been updated. However, the Policy GUID appears to have remained the same.
This means that the servers never obtain a "new" policy to execute on the Run Once ASAP schedule.


Solution



Upgrade the Task Server to the correct version. 
Check to make sure your Task Servers are up to date as well. The upgrade policy is in Settings > All Settings > Notification Server > Site Server Settings > Task Service > Advanced.
Wait for filters and collections to be updated.
After uploading the new inventory the client should not take more than an hour to be functional again. Usually the change is less than 15 minutes.

After upgrade to Latest HF for NS 7.5:
Add a new schedule to the policy and save it and update the agent policy on the task servers.




Article URL http://www.symantec.com/docs/TECH212593


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