Installation of NetBackup 7.5 or 7.6 hangs at the PDDE phase on some versions of AIX.

Article:TECH214505  |  Created: 2014-01-28  |  Updated: 2014-06-20  |  Article URL http://www.symantec.com/docs/TECH214505
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Environment

Issue



Installing NetBackup 7.5 GA or 7.6 GA (7.6.0.1) on AIX 7.1 TL3 or 6.1 TL9 hangs at the PDDE phase.

This issue has also been reported when attempting to apply the NetBackup 7.5.0.7 Maintenance Release to an existing NetBackup installation on these AIX versions.


Error



No previous install detected. Performing a fresh install.
+ Extracting PDDE server package (/usr/openv/pddeserver.tar.gz)...
Using /tmp/pdde_pkg to store temporary package data.
Unpacking SYMCpddes package.
Checking for pre-existing SYMCpddes package.
Installing SYMCpddes package.
+ Extracting PDDE agent package
(/usr/openv/netbackup/client/RS6000/AIX53/pddeagent.tar.gz)...
Using /tmp/pdde_pkg to store temporary package data.
Unpacking SYMCpddea package.
Checking for pre-existing SYMCpddea package.
Installing SYMCpddea package.
Creating /etc/pdregistry.cfg.
Saving a copy of the uninstall script to /opt/pdde/pddeuninstall.sh
Starting setup for PDDE script
pdregistry.cfg exists.

(hangs here)

ps -ef will show this process running :

pdcfg --read /etc/pdregistry.cfg --section="Symantec/PureDisk/StoragePoolAuthority" --option=configfilepath 2> /dev/null`


Environment



This issue has been reported on new installs of the following versions of NetBackup on the following versions of AIX:

  • NetBackup 7.5 GA, AIX 6.1 TL9, 64 bit
  • NetBackup 7.5 GA, AIX 7.1 TL3, 64 bit
  • NetBackup 7.6 GA (7.6.0.1), AIX 6.1 TL9, 64 bit
  • NetBackup 7.6 GA (7.6.0.1), AIX 7.1 TL3, 64 bit

Note: Installation of these NetBackup versions completes successfully without incident on these releases:

  • AIX 6.1 up to TL8
  • AIX 7.1 TL 0 through 2

This issue has also been reported when attempting to apply the NetBackup 7.5.0.7 maintenance release on these same AIX versions.


Cause



IBM updated AIX with a change to vswprintf that breaks undefined behavior in the libACE component shipped with the MSDP package. 

 


Solution



Symantec Corporation is aware that the above-mentioned issue (Etrack 3404636) is present in the version(s) of the product(s) mentioned in this article.  Symantec is committed to product quality and satisfied customers.  This issue was scheduled to be addressed in the following release:

  • NetBackup 7.6 Maintenance Release 2 (7.6.0.2)

When NetBackup 7.6.0.2 is released, please visit the following link for download and README information:
 http://go.symantec.com/nb

Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

NetBackup 7.6.0.2 will contain a workaround for the IBM issue until it is resolved in a future AIX Technology Level update.

In addtion, IBM has published the following iFixes for AIX 6.1 TL9 and 7.1 TL3

ftp://aix.software.ibm.com/aix/ifixes/iv56395/IV56395s1a.140310.61TL09SP00-01.epkg.Z
ftp://aix.software.ibm.com/aix/ifixes/iv56004/IV56004s1a.140310.71TL03SP00-01.epkg.Z

With this fix applied, NetBackup installations will succeed on AIX 6.1 TL9 and 7.1 TL3 without additional administrator intervention. This fix does require a reboot. If for some reason this iFix can't be applied, then follow the workaround process as documented.

 

Workaround:
When installing NetBackup 7.6 GA, a workaround exists: use touch to create /tmp/PDDE_SKIP_PACKAGE_SCRIPTS:

# touch /tmp/PDDE_SKIP_PACKAGE_SCRIPTS

The presence of this touchfile will allow an installation to complete, but the server can not be used as an MSDP server, nor use client-direct or PDDE storage units until a fix is delivered in NetBackup 7.6.0.2. Until 7.6.0.2 is released, an Emergency Engineering Binary (EEB) will be available for NetBackup 7.6.0.1 - please contact Symantec technical support, referencing this document ID and Etrack 3447902 to obtain this EEB.

New installations of NetBackup 7.5 are no longer recommended - instead, install NetBackup 7.6 GA using the workaround described above  and then apply the EEB fix that will be available until NetBackup 7.6.0.2 is released.  Once NetBackup 7.6.0.2 is released, the recommended solution will be to install NetBackup 7.6 and then immediately apply the NetBackup 7.6.0.2 maintenance release. 

The process for successfully installing NetBackup 7.5 when this issue is experience does not involve the /tmp/PDDE_SKIP_PACKAGE_SCRIPTS touch file as that functionality is new in 7.6. As a result, the 7.5 process requires more manual intervention to complete - as well as an immediate application of the NetBackup 7.5.0.7 maintenance release AND an EEB for 7.5.0.7 - and is not recommended with the availability of NetBackup 7.6.  If installing NetBackup 7.6 instead of NetBackup 7.5 is absolutely not an option, please contact Symantec technical support for further instructions as well as information on an EEB available for NetBackup 7.5.0.7.

For situations where applying the NetBackup 7.5.0.7 maintenance release is desired and upgrading to NetBackup 7.6 using the workaround described above is not an option, please contact Symantec technical support, referencing this document ID and Etrack 3404485 for further instructions.

 

---NEW OPTION AVAILABLE SINCE RELEASE OF 7.6.0.2---

Kill the install process of SYMCpddes, it will look like (ps -ef | grep installp and then kill -9 PID):

installp -a -d /tmp/pdde_pkg_dir_7929868/SYMCpddes.image SYMCpddes

The install will then continue (it will report an error on the SYMCpddes install)

Finish the install process.

Run installp -C to clean up the errored install.

Install NetBackup 7.6.0.2


Supplemental Materials

SourceETrack
Value3404636
Description

PDDE installation hangs on AIX 7.1 TL3



Article URL http://www.symantec.com/docs/TECH214505


Terms of use for this information are found in Legal Notices