Backup Exec 2012 Sp3 or hotfix fails to install with an error Patch has failed to fix BEDB data schema.

Article:TECH215215  |  Created: 2014-02-20  |  Updated: 2014-02-20  |  Article URL http://www.symantec.com/docs/TECH215215
Article Type
Technical Solution

Product(s)

Issue



Backup Exec service pack or hotfix fails to install with an error Patch has failed to fix BEDB data schema.  Table error in "vwGetJobHistoryResourceContainerMapping".


Error



"The OLE DB provider "SQLNCLI" for linked server "BESERVER_DB" does not contain the table ""BEDB"."dbo"."vwGetJobHistoryResourceContainerMapping"". The table either does not exist or the current user does not have permissions on that table"

 

V-225-1000: Patch has failed to fix BEDB data(schema). Rolling back patch process.
Connected to SQL Server SERVERNAME\BKUPEXEC.
V-225-205: ERROR -1: The OLE DB provider "SQLNCLI" for linked server "BESERVER_DB" does not contain the table ""BEDB"."dbo"."vwGetJobHistoryResourceContainerMapping"". The table either does not exist or the current user does not have permissions on that table.
CREATE PROCEDURE [dbo].[ReportFailedJobs] ( @protected_srv_names nvarchar(4000) = '', @numdays_befor
ERROR: -1 - Failed to execute dbupgradebuildtobuild.sql.
dbupgradebuildtobuild.sql changes did not complete successfully. Database schema may have been modified by this patch.
V-225-1000: Patch has failed to fix BEDB data(schema). Rolling back patch process.

 


Environment



Backup Exec 2012

Backup Exec 2012 Sp3


Cause



Missing View in Backup Exec database.

 


Solution



Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned in this article. Symantec Corporation is committed to product quality and satisfied customers.

 

This issue is currently under investigation by Symantec Corporation. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns. For information on how to contact Symantec Sales, please see http://www.Symantec.com Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.


NOTE: Customers experiencing this issue are encouraged to contact Symantec Technical Support as data is still being collected to assist in resolving this issue.

 

WORKAROUND:

NOTE: All the troubleshooting steps in (TECH212637) should be followed first or the following workaround will no be successful.  See Related Documents.

 

The last steps in TECH212637 indicated to run BEMIG from the command line.  This generally re-inserts the missing View in the Backup Exec database.

If after running BEMIG doesn't resolve the issue and the Backup Exec Service Pack and or hotfix fails to install with "vwGetJobHistoryResourceContainerMapping The table either does not exist" error please perform the following SQL query to re-insert the missing View in the Backup Exec Database.

 

1. Open a command prompt.
2. Type (without quotes) "cd c:\Program Files\Symantec\Backup Exec\"
3. Type (without quotes) "osql -E -S SERVERNAME\BKUPEXEC -d BEDB -i reports.sql"
 
Retry the installation of the Backup Exec service pack or hotfix.
 

 

 





Article URL http://www.symantec.com/docs/TECH215215


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