Getting error message 'Page cannot be displayed' when Incident Tab or Incident Settings pages are open.

Article:TECH24290  |  Created: 2006-10-27  |  Updated: 2010-04-06  |  Article URL http://www.symantec.com/docs/TECH24290
Article Type
Technical Solution

Issue



When you try to open the Incidents Tab or the Incident Settings (under Configuration Tab>Server Settings>Notification Server Settings) pages, you get the page saying 'Page cannot be displayed'.

When you look on the NSRedirect (under IIS manager>Web Sites>Default Web Site>Right-click Properties>ISAPI Filters tab), it has the Down status (Red arrow down) and Unknown priority. If you restart IIS, it comes back to Up status but if you go to the Incidents Tab or Incidents Settings page, it goes back to down status.

Looking on the Events Logs, under the Application Logs, you may see errors like these ones:

Event Type: Error
Event Source: W3SVC-WP
Event Category None
Event ID: 2268
Date: 10/27/2006
Time: 10:14:57 AM
User: N/A
Computer: AltirisServer
Description:
Could not load all ISAPI filters for site/service. Therefore startup aborted.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 05 00 00 00 ....


================================

Event Type: Error
Event Source: W3SVC-WP
Event Category: None
Event ID: 2214
Date: 10/27/2006
Time: 10:14:57 AM
User: N/A
Computer: AltirisServer
Description:
The HTTP Filter DLL C:\Program Files\Altiris\Notification Server\bin\Isapi\NsRedirect.dll failed to load. The data is the error.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 05 00 00 00 ....


Environment



Notification Server 6.0.6074
IIS 6.0
HelpDesk Solution

Cause



The Identity security account is not setup properly for the Application Pools and DefaultAppPool under IIS manager.

Solution



Change the Helpdesk IIS application pools to use Network Service.

  1. In Windows, click on Start > Administrative Tools > Event Viewer.
  2. Click on the Application log to open it.
  3. Search for errors matching those from the Problem/Symptoms section.
  4. These should be found and if so, in Windows, click on Start > Administrative Tools > Internet Information Services (IIS) Manager.
  5. Click on <computer name> > Application Pools > AeXHD.
  6. Right click on AeXHD and click on Properties.
  7. Click on the Identity tab.
  8. Change the Predefined to Network Service.
  9. Click on the OK button.
  10. Repeat steps 6 through 9 for AeXKB and DefaultAppPool.
  11. In Windows, click on Start > Run.
  12. Type iisreset in the Open field.
  13. Click on the OK button.
  14. In Windows, navigate to the <Altiris_installation_drive>:\Program Files\Altiris\Setup Files\Altiris Helpdesk folder.
  15. Right click on AlertManager.msi and click on Repair.
  16. After the repair finishes, open a new Altiris Console, and go to Incident Settings. The issue should now be resolved.

Legacy ID



28974


Article URL http://www.symantec.com/docs/TECH24290


Terms of use for this information are found in Legal Notices