All selections for remote machines are unavailable for selection

Article:TECH24413  |  Created: 2007-01-23  |  Updated: 2012-12-11  |  Article URL http://www.symantec.com/docs/TECH24413
Article Type
Technical Solution

Product(s)

Issue



All selections for remote machines are unavailable for selection

 


Cause



This issue may also occur due to one of the following causes (but can also come up to other environmental conditions)
  • The Remote Agent for Windows Servers is not installed on the target server
  • Another application is using the default Network Data Management Protocol (NDMP) port of 10000
  • Name resolution issue
  • Port 10000 communications are being blocked by a firewall or some other mechanism

Solution



    I. The Remote Agent for Windows Servers is not installed on the target server:

To verify whether the Remote Agent for Windows Servers is installed, right-click on the computer whose selections are unavailable, and select Properties (Figure 1 and Figure 2). The dialog box will indicate the version of the Remote Agent, and the exact state of the service.

Figure 1
 

Figure 2
 

    II. Another application is using the default NDMP port of 10000:

If the Remote Agent for Windows Servers is installed and running on the remote computer, it is possible that the default port for Network Data Management Protocol (NDMP) is in use by another application on the network. By default, NDMP uses port 10000 for its control session. This port can be changed to a different port if needed. To determine if another application has the port open on either the Backup Exec (tm) Media Server or on the remote server running Remote Agent 9.x for Windows Servers, perform the following procedures.

On the Backup Exec Media Server:
 
1. Start BEUtility 
Note: By default
For 10d and 11d the default path is C:\Program Files\Symantec\Backup Exec\NT
For 12.0 and above the default path is C:\Program Files\Symantec\Backup Exec\
 
2. From the right pane, select the Backup Exec Media Server (if it is not listed, right-click on All Media Servers, and then select New Media Server).
 
3. Under Services Tasks, select Stop Services
 
4. Go to Start | Run, and type CMD to display the command prompt window
 
5. Type netstat -a and then press <Enter>. This will list all the ports that the server is listening on.
 
6. If there are any entries for port 10000, then this port is being used by another application. To change to a port for NDMP, see the Related Documents section at the end of this document.

On the remote server running Remote Agent for Windows Servers:
 
1. Open Services from the Control Panel, go to Start | Programs | Administrative Tools for Windows 2003
 
2. Stop the Backup Exec Remote Agent for Windows Servers service
 
3. Go to Start | Run, and type CMD to display the command prompt window
 
4. Type netstat -a and press <Enter>. This will list all the ports that the server is listening on
 
5. If there are any entries for port 10000, then this port is in use by another application. To change to a port for NDMP, see the Related Documents section at the end of this document
 
III. Testing for a possible name resolution issue:

If in both cases, port 10000 is not in use by a different application, attempt to create a User Defined Share to the IP Address. To do this, perform the following:
 
1. Start Backup Exec
 
2. Click Backup
 
3. From the Backup Job Properties window click Selections 
 
4. Click Remote Selections, and then select User Defined Selections
 
5. Right-click User Defined Selections, and select User Defined Selections
 
6. Type the IP Address for the remote server, and click Add, and then click Close
 
7. Select the remote server by IP Address, under User Defined Selections

If the computer is not selectable, then in most cases the issue lies somewhere in the name resolution for the environment. Verify that all  Windows Internet Naming Service (WINS) and Domain Name Service (DNS) Settings are correct. Verify that all entries in the WINS and DNS database are correct, and that there are no orphaned entries. Also check all LMHOSTS and HOSTS files on the backup server and the remote server, and verify that there are no incorrect entries. If there are no entries inside either of these files, add in entries for the servers in the environment, to see if the problem is alleviated.

IV. Port 10000 communications are being blocked by a firewall or some other mechanism:

If the computer still cannot be selected in selection list, then in most cases, the Backup Exec Job Engine is unable to establish its control session over port 10000. This is usually caused when the remote server is behind a firewall, and port 10000 is closed. For more information on allowing Remote Agent communication through the built in Microsoft Windows XP Service Pack 2 firewall, see the Related Documents section below.



Legacy ID



255500


Article URL http://www.symantec.com/docs/TECH24413


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