"Object reference not set to an instance of an object" opening winuser console

Article:TECH24490  |  Created: 2006-11-01  |  Updated: 2007-01-18  |  Article URL http://www.symantec.com/docs/TECH24490
Article Type
Technical Solution

Issue



Multiple users receive "Object reference not set to an instance of an object" when they try to open the winuser console. The full exception is below:

Exception - System.NullReferenceException:
Object reference not set to an instance of an object.
   at Altiris.Helpdesk.Services.CurrentWorker.get_Tags(String tag_name)
   at _ASP.CustomConsoleMyHD_ascx.LoadDataSources()
   at Altiris.AppWeaver.TemplateModule.OnLoad(EventArgs e)

Environment



Helpdesk 6.0.297 (SP4)

Cause



This may happen when custom tags have been set in the tag table for the guest account.

Solution



The Winuser console uses the helpdesk guest account for everyone so the tags for the guest contact will need to be reset using the steps outlined below.  Before going through the steps you it is recommended to backup your database first.

First verify the guest account's contact_id by running the following query:

SELECT contact_id
FROM worker
WHERE status = 'g'

Then verify the tag_collection_id for the guest account by using the contact_id from the above query in the next query:

SELECT
tag_collection_id
FROM contact
WHERE id = put_contact_id_here

Then, making sure to have a good backup of the database first, delete the tags for the guest account from the tag table by using the tag_collection_id from the above query in the next query:

DELETE
FROM
tag
WHERE tag_collection_id = put_tag_collection_id_here

Then, because the guest account is involved, restart IIS on the Helpdesk server so that these changes will take effect.


Legacy ID



29062


Article URL http://www.symantec.com/docs/TECH24490


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