Error: Could not open INSTALL.LOG file (WiseScript)

Article:TECH25237  |  Created: 2006-11-13  |  Updated: 2007-01-24  |  Article URL http://www.symantec.com/docs/TECH25237
Article Type
Technical Solution


Issue



Uninstall of an installation created with WiseScript fails with the following error:

Could not open INSTALL.LOG file.


Environment



Wise Package Studio

Cause



There are three possible reasons why the uninstall program cannot locate the installation log:

  1. The installation did not create a log.
  2. The uninstall string in the registry is not accurate.
  3. The end user has accidentally deleted the installation log.

Solution



There are three possible reasons why the uninstall program cannot locate the installation log:

  1. The installation did not create a log.

    Open the Installation Log page in Installation Expert and mark an option other than Do not create installation log. Select the location for the installation log in the Destination Computer window and enter the file name for the log in the Install Log File Name field.
  2. The uninstall string in the registry is not accurate.

    The installation log is located in a directory with a long filename (for example, C:\Program Files\Sample), and the registry key related to the uninstall program (HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\) does not correctly point to the directory. The uninstall registry key may have a value of C:\Program Files\Sample\UNWISE.EXE C:\Program Files\Sample\INSTALL.LOG. When the uninstall attempts to execute, the command stops after C:\Program because of the space character and then uninstall fails. To resolve this issue, the registry key should read "C:\Program Files\Sample\UNWISE.EXE" "C:\Program Files\Sample\INSTALL.LOG" (including the quotes) or C:\PROGRA~1\SAMPLE\UNWISE.EXE C:\PROGRA~1\SAMPLE\INSTALL.LOG (not including quotes).
  3. The end user has accidentally deleted the installation log.

    The end user has deleted the installation log since first running the installation. The end user must reinstall the program, which re-creates the installation log, to uninstall the program.

Legacy ID



29380


Article URL http://www.symantec.com/docs/TECH25237


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