KNOWN ISSUE: Patch Management Dashboard times out or is slow to render

Article:TECH25255  |  Created: 2006-11-15  |  Updated: 2009-03-31  |  Article URL http://www.symantec.com/docs/TECH25255
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Problem



Under the Reports tab when I click on the Patch Management Dashboard, the page either takes a long time to render, or times out.

Environment



Patch Management 6.2

Cause



The SQL Stored Procedure used to populate this page is ineffecient and must be modified.

Solution



Download the new Stored Procedure attached to the KB.

Instructions to update:

  1. Unzip the file to a convenient location.
  2. Open SQL Query Analyzer.
  3. Select the Altiris database.
  4. Copy and paste the contents of the .sql file into Query Analyzer.
  5. Execute query.

*Note: Even after applying the modified stored procedure, the Patch Management dashboard, on occasion, fails to render.  If this is the case, download the attached SQL queries, which will create Indexes on heavily used tables.

Note: KB46144 Combined fixes for known Patch Report Discrepencies, Dashboard issues etc also includes this fix and several more.


Supplemental Materials

SourceDEFECT
ValueSYD 26811
DescriptionLogged in sydd2 (Altiris - Sydney) database

Legacy ID



29419


Article URL http://www.symantec.com/docs/TECH25255


Terms of use for this information are found in Legal Notices