The Preflight Analysis website functions but displays an empty job list

Article:TECH25681  |  Created: 2006-12-20  |  Updated: 2009-10-19  |  Article URL http://www.symantec.com/docs/TECH25681
Article Type
Technical Solution

Product(s)

Issue



The Preflight Analysis website functions, but displays an empty job list.

Running a preflight MSI on any computer in the organisation does not create a new job on the Preflight Analysis web page.

* Investigation into the IIS logs shows that the MSI does communicate without visible errors with the web service .DLL.
* The preflight .MSI verbose log reveals no errors.
* A trace on the SQL server shows no successes or failures of  logins during the time which the preflight .MSI is run.
* The config.ini file contains the correct information.
* The Run table in the Wise Services Database was empty.  This table should contain an entry for each time a preflight .MSI is run.

Environment



Wise Package Studio 7.0 SP1
Windows 2003 Server
SQL 2000 SP4

Cause



Permissions on the IUSR and IWAM accounts in the following registry caused the problem:

HKEY_LOCAL_MACHINE\Software\Wise Solutions\Wise Managed Enterprise

Make sure both of these accounts have Full Control:

Internet Guest Account (servername\IUSR_servername) and
Launch IIS Process Account (servername\IWAM_servername)

Solution



The problem is registry permissions.

Check the entire HKEY_LOCAL_MACHINE\Software\Wise Solutions tree and ensure that the ID values that reference IUSR and IWAM accounts are up to date. These values can change if IIS is reinstalled. If old values are found, remove old IDs, add the correct IUSR and IWAM accounts manually (with full control). Test the preflight .MSI again.


Legacy ID



31214


Article URL http://www.symantec.com/docs/TECH25681


Terms of use for this information are found in Legal Notices