Error "An unexpected error has occurred. Exception of type System.OutOfMemoryException was thrown" occurs or Helpdesk times out when trying to create, edit or view an incident

Article:TECH25700  |  Created: 2006-12-21  |  Updated: 2011-08-03  |  Article URL http://www.symantec.com/docs/TECH25700
Article Type
Technical Solution

Issue



When an incident is created, edited or viewed, the error "An unexpected error has occurred. Exception of type System.OutOfMemoryException was thrown" occurs or Helpdesk times out.


Error



An unexpected error has occurred. Exception of type System.OutOfMemoryException was thrown.

Exception - Altiris.Helpdesk.Services.ListException: An unexpected error has occurred. Exception of type System.OutOfMemoryException was thrown. ---> System.OutOfMemoryException: Exception of type System.OutOfMemoryException was thrown.

Environment



Helpdesk 6.x


Cause



Helpdesk incidents that have comments exceeding 4,000 characters in even one incident can cause .NET to overflow and the Helpdesk database (Altiris_Incidents) to increase substantially in size. The more incidents that have this issue, the more frequent the slow performance, timeouts or out of memory errors will occur.

 


Solution



Truncate or delete incidents that have large comments and apply business rules to prevent future occurrences. Refer to the following article for more information:

Incidents with large comments cause slow performance, timeouts or out of memory errors in Helpdesk
http://www.symantec.com/business/support/index?page=content&id=TECH145515

Related Article

Slow performance, timeouts, out of memory errors or high CPU/w3wp.exe/IIS usage occurs when using Helpdesk
http://www.symantec.com/business/support/index?page=content&id=TECH146510



Legacy ID



31280


Article URL http://www.symantec.com/docs/TECH25700


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