Recovery Solution Server uninstall and reinstall

Article:TECH25938  |  Created: 2007-01-11  |  Updated: 2012-03-07  |  Article URL http://www.symantec.com/docs/TECH25938
Article Type
Technical Solution

Issue



Possible reasons for uninstallation and reinstallation of RS Server:

  1. Reinstallation of the RS Server is not always a fix for a problem, but can be a troubleshooting step.
  2. The RS Server isn’t working after the upgrade from a previous version.
  3. The Altiris Agent Details show the incorrect version for the RS server agent after an upgrade.
  4. RS Server jobs have hung and don’t seem to have completed. The application log shows the server job has begun, but the job is taking much longer than previous jobs have.
  5. RS Server hotfix specific to fix AeXVault.exe crashes didn’t stop the crashes from occurring. (This would be one of the troubleshooting steps. Reinstallation, and the re-application of the hotfix has solved this problem with some previous incidents.)
  6. When the Recovery Solution Server is not running server jobs the Altiris Recovery Solution Service will not restart.
  7. The Recovery Solution Server isn’t detected correctly after the cluster has been installed. The Cluster may or may not recognize it as an active server but doesn’t list it as an available server.

Environment



Recovery Solution 6.1 RS 6.2


Cause



RS server has become corrupt and needs to be reinstalled.


Solution



Uninstall RS Server:

  1. Use the Recovery Solution Server Uninstall task in the configuration task in the following location: Configuration tab > Solution Settings > Incident Management > Recovery Solution > Recovery Solution Clusters > Recovery Solution Cluster Configuration >> Recovery Solution Server Uninstall.
  2. Select the correct cluster.
  3. Select the RS server and use the button Uninstall Server to initiate the uninstallation.
  4. Open the Altiris Agent details on the RS server and watch for the Altiris RS Server Agent to disappear from the installed agent box.
  5. Open the Add or Remove Programs to verify that the Altiris Recovery Solution Server is no longer listed there.
  6. Open the Services Console and verify that the following services are no longer listed:
    • Altiris Recovery Server host Manager (ping service)
    • Altiris Recovery Solution Server
  7. Open up the Task Manager, select Show processes from all users, and sort by Image name to verify that the AeXVault.exe is no longer running. (This is the process associated with the Altiris RS Server service.)
  8. When all of these locations no longer list references or services associated with the RS Server, it is fully uninstalled. It does not require the reboot of the server. However, if there are ongoing problems with the RS server and it’s possible to reboot the server, reboot the server now.

Manual Uninstall of the RS Server:

  1. If logged on locally to the RS server, go to Add or Remove Programs in Control Panel.
  2. If logging on to the RS server remotely, please use the console command to open up the connection. Enter the following command in the Run window:  MSTSC /CONSOLE
  3. Once in the Add or Remove Programs window select the Altiris Recovery Solution Server and choose to remove it.
  4. Check the same locations as listed above to verify the server portion was removed.
    1. Open the Altiris Agent details on the RS server and watch for the Altiris RS Server Agent to disappear from the installed agent box.
    2. Open the Add or Remove Programs to verify that the Altiris Recovery Solution Server is no longer listed there.
    3. Open the Services Console and verify that the following services are no longer listed:
      • Altiris Recovery Server host Manager (ping service)
      • Altiris Recovery Solution Server
    4. Open up the Task Manager, select Show processes from all users, and sort by Image name to verify that the AeXVault.exe is no longer running. (This is the process associated with the Altiris RS Server service.)
    5. When all of these locations no longer list references or services associated with the RS Server, it is fully uninstalled. It does not require the reboot of the server. However, if there are on going problems with the RS server and it’s possible to reboot the server, reboot the server now.

Reinstall of the RS Server:

  1. Use the Recovery Solution Server Install task in the configuration task to initiate the install in the following location: Configuration tab > Solution Settings > Incident Management > Recovery Solution > Recovery Solution Clusters > Recovery Solution Cluster Configuration.
  2. Use the blue plus sign to select the Server to which you would like to install the RS Server and click the Install Server button. You can choose a location to put the program in the next window.
  3. Watch the following locations on the RS Server (which are the same as listed above) to verify that the RS Server is installed and starts running:
    1. Open the Altiris Agent details on the RS server and watch for the Altiris RS Server Agent to appear in the installed agent box.
    2. Open the Add or Remove Programs to verify that the Altiris Recovery Solution Server is listed there.
    3. Open the Services Console and verify that the following services are listed and running:
      • Altiris Recovery Server host Manager (ping service)
      • Altiris Recovery Solution Server
    4. Open up the Task Manager, select Show processes from all users, and sort by Image name to verify that the AeXVault.exe is longer running. (This is the process associated with the Altiris RS Server service.)
    5. Check the Recovery Solution cluster Servers tab to verify that it’s listed there, that the status is Enabled and Service Status is Running.



Legacy ID



31860


Article URL http://www.symantec.com/docs/TECH25938


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