Client Task Agent error: 'Unable to register'. OS error = 2147549183.

Article:TECH26067  |  Created: 2007-01-22  |  Updated: 2007-09-12  |  Article URL http://www.symantec.com/docs/TECH26067
Article Type
Technical Solution


Issue



The following error appears in the Altiris Agent Log:

Log File Name: C:\Program Files\Altiris\Altiris Agent\Logs\Agent.log
Priority: 2
Date: 1/22/2007 1:43:18 PM
Tick Count: 11604927
Host Name:
Process: AeXNSAgent.exe (3860)
Thread ID: 2732
Module: Client Task Agent.dll
Source: Client Task Agent
Description: CAtrsException exception, error = "Unable to register", OS error = 2147549183, at line 440  re-throw at CTaskAgentBase::CheckRegister

Additionally the following error came up when trying to manually run 'register.aspx' on the task server computer.

<response result="failure">![CDATA[An exception occurred while attempting to register the client. Error: System.Exception: We cannot service this request because the web application failed to initialize. ---> System.Exception: Unable to configure remoting during Application Start ---> System.Security.SecurityException: Requested registry access is not allowed. at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable) at Microsoft.Win32.RegistryKey.OpenSubKey(String name) at Altiris.ClientTask.Configuration.AltirisAgentConfiguration.get_AltirisServerWeb() at Altiris.ClientTask.Server.Web.SubAgentCache.Initialize() at Altiris.ClientTask.Server.Web.WebClientApiManager.Initialize(String configFilePath) at Altiris.ClientTask.Server.Web.Global.Application_Start(Object sender, EventArgs e) --- End of inner exception stack trace --- --- End of inner exception stack trace --- at Altiris.ClientTask.Server.Web.WebClientApiManager.ProcessRegister(NameValueCollection queryValues, Stream requestStream, Int32 contentLength)]]</response>


Environment



Notification Server 6.0 SP3 R3, R5
Task Server 6.0.1356

Cause



Insufficient rights on the remote task server registry key of "Hkey_Local_Machine\Software\Altiris\Altiris Agent\Servers". 

Solution



In looking at the registry key as being an issue, it was found that the administrators were listed as having full control and read. No more rights were listed. After adding PowerUsers with read and special, System with full and read, and Users with read and running IISreset, the agents began to register. The remote task server in question was running IIS.

Another cause for the agent log error "Description: CAtrsException exception, error = "Unable to register", OS error = 2147549183, at line 440  re-throw at CTaskAgentBase::CheckRegister" would be if the asp.net is not installed on the task server.


Legacy ID



32117


Article URL http://www.symantec.com/docs/TECH26067


Terms of use for this information are found in Legal Notices