KNOWN ISSUE : E-mail macros are not resolving consistently

Article:TECH26100  |  Created: 2007-01-24  |  Updated: 2007-02-02  |  Article URL http://www.symantec.com/docs/TECH26100
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Issue



When using e-mail macros like Workitem_Link, Worker_Link, and Winuser_Link, they do not resolve correctly. For example, one time it will resolve as http://<Helpdesk_Server_Name>/aexhd/, and the next time it will be https://<Helpdesk_Server_Alias>/aexhd/.

Environment



Helpdesk 6.0.297

Solution



Workaround:  The links that are created from using the e-mail macro is from using a string "emailviewworkitemurl". This string is declared in the Formats.xml file which is found in C:\\Program Files\Altiris\Helpdesk\Aexhd\bin.

By default, the string uses ~/default.aspx?cmd=viewItem&id={0}, and to resolve this you will need to change it. You want to edit and remove the tilde (~) and then add the full URL you want displayed for the link.

It is recommended that you should not edit the Formats.xml file directly. If you are needing to edit the Formats.xml, use a custom.config file to apply your changes to your Helpdesk. This information is found in the Product Guide for Helpdesk starting on page 191 in the Customization chapter.


Supplemental Materials

SourceDEFECT
ValueABQ 4198
DescriptionLogged in abqdc01 (Altiris - Albuquerque) database

Legacy ID



32197


Article URL http://www.symantec.com/docs/TECH26100


Terms of use for this information are found in Legal Notices