PC Transplant Solution Realtime migration extremely slow when migrating large profiles

Article:TECH26208  |  Created: 2007-02-04  |  Updated: 2007-02-04  |  Article URL http://www.symantec.com/docs/TECH26208
Article Type
Technical Solution

Issue



The PCT real time migration process is running extremely slow. One example of a migration showed a profile with an approximate size of 20GB taking 8 hours.

Environment



All versions of PCT


Cause



Although the root cause is not known it was found that the destination machines that were being migrated to had corruption in the window security database. It would appear that in part this created a performance hit on the real time migration leading to approximately only 600k of data being transferred a second. For a larger sized personality this would push out the duration time for the migration to unacceptable levels.

Solution



MS KB 892891 (http://support.microsoft.com/kb/892891) was followed to identify Windows security database corruption and then remediate against the corruption.

To verify whether the Windows security database is corrupted, follow these steps:

(1) Click Start, click Run, type cmd, and then click OK.

(2) At the command prompt, type:

esentutl /g %windir%\security\database\secedit.sdb
 
If the Windows security database is corrupted, the output will contain the following line:

This operation may find that this database is corrupt.

To work around this problem, follow these steps:

(1) If both the Edb.log file and the Edb.chk file are in the %windir%\security directory, follow these steps to repair the security database:

a.  Click Start, click Run, type cmd, and then click OK.
b.  At the command prompt, type

esentutl /r edb /l %windir%\security /s %windir%\security  
 
(2) If either the Edb.log file or the Edb.chk file is in the C:\WINDOWS\security directory, or if neither file exists in the directory, follow these steps to repair the security database:

a.  Click Start, click Run, type cmd, and then click OK.
b.  At the command prompt, type

esentutl /p %windir%\security\Database\secedit.sdb 

c.  Click OK when you receive the following message:

You should only run Repair on damaged or corrupted databases. Repair will not apply information in the transaction log files on the database, and may cause information to be lost. Do you wish to proceed?

Further to this the following actions were performed in order to optimise performance of the migration:

(1) The DS was configured to perform the real time migration as per the below Altiris kb:

http://kb.altiris.com/article.asp?article=25745&p=3

(2) As part of the DS job, all PCT files required for the migration are first copied down to the source machine, refer akb:

http://kb.altiris.com/article.asp?article=22873&p=3

(3) PCT was utilised purely for the settings/printers portion of the profile migration and via the DS run script task and custom data source as configured in (1), MS Robocopy was used to migrate the majority of data as this did not appear to have a performance hit.


Legacy ID



32443


Article URL http://www.symantec.com/docs/TECH26208


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