Hotfix 7: System variables do not work on Microsoft Windows XP French

Article:TECH26325  |  Created: 2007-02-13  |  Updated: 2007-03-19  |  Article URL http://www.symantec.com/docs/TECH26325
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Article Type
Technical Solution


Issue



System variables do not work on the French version Windows XP*.

Environment



Recovery Solution 6.2.2332
Microsoft Windows XP French

Cause



The Recovery Agent could not accept any user's environment variables specified for snapshots, excludes, or exceptions on Microsoft Windows XP French. This was due to the console code not allowing the specified environment variables for scheduled snapshots.

Solution



The hotfix is in the form of the attached VolAgent.dll.

The hotfix VolAgent.dll should be implemented the following way on Microsoft Windows XP French:

  1. Stop the Recovery Agent Service on the Microsoft Windows XP French client computer.
  2. Replace the old VolAgent.dll with the new VolAgent.dll at %Program Files%\Altiris\eXpress\Client Recovery Agent.
  3. Restart the Recovery Agent Service.

VolAgent.dll should be updated to the Data1.cab (which are present in the Recovery Solution Agent package) which can be modified using the ASPack.exe utility. Whenever a client side fix is replaced on the client computer, the fix can be updated on the Recovery Solution Agent package so that the next time the Recovery Solution Agent is installed on a new client computer so that the fix is automatically present on the client computer.

The Data1.cab, should be modified on the following locations:

  1. Folder Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\Recovery Agent Package located on the Notification Server.
  2. Folder Program Files\Altiris\Recovery Solution\Server\Agent\Install located on the Recovery Solution Server.
  3. Folder Program Files\Altiris\Recovery Solution\Server\Agent\Package located on the Recovery Solution Server.

The fix can be replaced in the Data1.cab the following way:

  1. Use ASPack.exe to modify Recovery Solution Agent package.
  2. Locate ASPack.exe in folder C:\Program Files\Altiris\Recovery Solution\Console\Tools.
  3. Launch ASPack.exe from C:\Program Files\Altiris\Recovery Solution\Console\Tools.
  4. For the Source Package, browse to Program Files\Altiris\Notification Server\NSCap\Bin\Win32\X86\Recovery Agent Package\Data1.cab in ASPack.exe.
  5. Select Action as Modify Package files from the drop down list and click Start.
  6. After clicking Start, the list of files contained in Data1.cab or AgentSetup.exe will be shown.
  7. Click the Add button and add the new fix.
  8. After the new fix has been added click next and a message will be displayed, “The package has been modified. Press the Finish button to save changes.” Click Finish.
  9. After the package has been saved, continue modifying the Data1.cab or AgentSetup.exe on the other two remaining locations, i.e. Program Files\Altiris\Recovery Solution\Server\Agent\Install and Program Files\Altiris\Recovery Solution\Server\Agent\Package by repeating steps 1 to 8 again.

Attachments

VolAgent.zip (343 kBytes)

Legacy ID



32729


Article URL http://www.symantec.com/docs/TECH26325


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