Files are installed to current users Application Data folder instead of All Users Application Data folder
| Article:TECH26418 | | | Created: 2007-02-20 | | | Updated: 2009-11-01 | | | Article URL http://www.symantec.com/docs/TECH26418 |
| NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made. |
Problem
Steps to reproduce:
- Run SetupCapture tool.
- Click Next on the Welcome dialog.
- Specify a location for the .wsi in the Target Installation field. Click Next.
- Click Next again.
- Select Snapshot on the Capture Methodology dialog. Click Next.
- Browse to C:\Windows\Notepad.exe in the .EXE Name field. Click Execute.
- When Notepad is launched, enter some text and save the file to C:\Documents and Settings\All Users\Application Data\test.txt.
- Close Notepad.
- Click Next through the remaining dialogs in the SetupCapture wizard.
- Run the compiled .msi.
The file is installed to C:\Documents and Settings\<current user>\Application Data instead of C:\Documents and Settings\All Users\Application Data.
Environment
Wise Package Studio 7.0 SP2
Cause
After the SetupCapture is completed, the value in the Directory_ field in the Component table is AppDataFolder instead of CommonAppDataFolder.
Solution
This issue has been fixed Wise Package Studio 7 SP3.
A hotfix has been created for this issue. This hotfix can only be installed to a machine that has Wise Package Studio 7.0 SP2.
- Download the hotfix from here
- Unzip and run WPS_7.0_SP2_HF32880.EXE on a computer with Wise Package Studio 7.0 SP2 server.
If you do not want to install the hotfix, the following steps will allow you to workaround the issue:
- Go to Installation Expert > Files page.
- Windows\Profiles\All Users so that the Application Data folder can be seen.
- Select Windows\Profiles\Application Data.
- Highlight the files that should go to All Users\Application Data.
- Drag them into the Windows\Profiles\All Users\Application Data folder.
Attachments
|
|
|
| Source | DEFECT |
| Value | LB 57957 |
| Description | Logged in Littlebuggy (Altiris - Lindon, Plymouth) database |
Legacy ID
32880
Article URL http://www.symantec.com/docs/TECH26418
Terms of use for this information are found in Legal Notices









Thank you.