Files are installed to current users Application Data folder instead of All Users Application Data folder

Article:TECH26418  |  Created: 2007-02-20  |  Updated: 2009-11-01  |  Article URL http://www.symantec.com/docs/TECH26418
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Article Type
Technical Solution


Issue



Steps to reproduce:

  1. Run SetupCapture tool.
  2. Click Next on the Welcome dialog.
  3. Specify a location for the .wsi in the Target Installation field. Click Next.
  4. Click Next again.
  5. Select Snapshot on the Capture Methodology dialog. Click Next.
  6. Browse to C:\Windows\Notepad.exe in the .EXE Name field. Click Execute.
  7. When Notepad is launched, enter some text and save the file to C:\Documents and Settings\All Users\Application Data\test.txt.
  8. Close Notepad.
  9. Click Next through the remaining dialogs in the SetupCapture wizard.
  10. Run the compiled .msi.

The file is installed to C:\Documents and Settings\<current user>\Application Data instead of C:\Documents and Settings\All Users\Application Data.


Environment



Wise Package Studio 7.0 SP2

Cause



After the SetupCapture is completed, the value in the Directory_ field in the Component table is AppDataFolder instead of CommonAppDataFolder.


Solution



This issue has been fixed Wise Package Studio 7 SP3.

A hotfix has been created for this issue. This hotfix can only be installed to a machine that has Wise Package Studio 7.0 SP2.

  1. Download the hotfix from here
  2. Unzip and run WPS_7.0_SP2_HF32880.EXE on a computer with Wise Package Studio 7.0 SP2 server.
Note for Wise Package Studio users: This hotfix also needs to be executed on any Wise Package Studio clients that were installed as Local clients. If the clients were installed as Network clients, nothing needs to be done to the client as it runs the executables from the server location.


If you do not want to install the hotfix, the following steps will allow you to workaround the issue:

  1. Go to Installation Expert > Files page.
  2. Windows\Profiles\All Users so that the Application Data folder can be seen.
  3. Select Windows\Profiles\Application Data.
  4. Highlight the files that should go to All Users\Application Data.
  5. Drag them into the Windows\Profiles\All Users\Application Data folder.

Attachments

WPS_7.0_SP2_HF32880.zip (5.4 MBytes)

Supplemental Materials

SourceDEFECT
ValueLB 57957
DescriptionLogged in Littlebuggy (Altiris - Lindon, Plymouth) database

Legacy ID



32880


Article URL http://www.symantec.com/docs/TECH26418


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