Unable to install Web applications on Windows Vista

Article:TECH27625  |  Created: 2007-03-20  |  Updated: 2007-11-29  |  Article URL http://www.symantec.com/docs/TECH27625
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution



Issue



Running an .msi that creates a web site or virtual directory results in a Fatal Error on Windows Vista*.

Steps to reproduce:

  1. Create a new .wsi.
  2. Add a file on the Files page.
  3. Create a new virtual directory on the Web Files page.
  4. Compile and run the .msi on a Windows Vista computer.

Environment



Wise Installation Studio 7.0
Wise Package Studio 7.0 SP1 and greater

Cause



The IIS 6 Metabase and IIS 6 configuration compatibility is not enabled.


Solution



This issue has been fixed in Wise Installation Studio/Express 7 SP1.  The fix for this issue will also be included with the next release of Wise Package Studio.

Workaround:
The APIs used for our implementation of creating Web sites and virtual directories require the IIS 6 Metabase and IIS 6 configuration compatibility enabled when installing on Windows Vista.

Perform the following steps to enable IIS 6 configuration compatibility:
  1. In Windows Vista, go to Control Panel > Programs and Features.
  2. Click Turn Windows features on or off.
  3. In the Windows Features dialog, drill-down to Internet Information Services > Web Management Tools > IIS 6 Management Compatibility. Enable the IIS Metabase and IIS 6 configuration compatibility option.

Supplemental Materials

SourceDEFECT
ValueLB 57186
DescriptionLogged in Littlebuggy (Altiris - Lindon, Plymouth) database

Legacy ID



33740


Article URL http://www.symantec.com/docs/TECH27625


Terms of use for this information are found in Legal Notices