Recovery Solution 6.2.2332 HotFix #19: Recovery Server Host Manager hangs

Article:TECH28459  |  Created: 2007-04-05  |  Updated: 2007-04-05  |  Article URL http://www.symantec.com/docs/TECH28459
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Article Type
Technical Solution

Issue



The Recovery Agent states that the Recovery Server is unavailable despite the Recovery Solution Server Service on the Recovery Server is running. When restarting the Altiris Recovery Server Host Manager (AHMS) and Altiris Recovery Solution Service Services, the AHMS service cannot be stopped.  

Altiris Recovery Server Host Manager (AHMS) - Ping service is hung.


Environment



Recovery Solution 6.2.2332

Cause



Constant change of IP table on the Recovery Solution Server is incorrectly detected by AHMS.exe module used by Altiris Recovery Server Host Manager (ping service).

Establishing VPN/RAS connection, manually (or over DHCP) changing of IP addresses for locally installed network adapters can cause change in IP table also.

Solution



The resolution is in the form of AHMS.exe which should be implemented on the Recovery Solution Server in the following way:

  1. Ensure that the Altiris Recovery Server Host Manager (AHMS) and Altiris Recovery Solution Server Services are stopped.
  2. Update the AHMS.exe at %Program Files%\Altiris\Recovery Solution\Server.
  3. Restart the Altiris Recovery Server Host Manager (AHMS) and Altiris Recovery Solution Server Services.

Attachments

Ahms.exe (396 kBytes)

Supplemental Materials

SourceDEFECT
ValueTLN 22163
DescriptionLogged in tlndev (Altiris - Talinn) database

Legacy ID



34169


Article URL http://www.symantec.com/docs/TECH28459


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