Hotfix 18: Restored EFS encrypted files are corrupted after Full System Recovery (FSR)

Article:TECH29579  |  Created: 2007-05-06  |  Updated: 2007-11-07  |  Article URL http://www.symantec.com/docs/TECH29579
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Article Type
Technical Solution

Issue



Restored EFS encrypted files are corrupted after Full System Recovery (FSR).

Environment



Recovery Solution 6.2.2332

Cause



The feclient.dll file is not included on the must-have list in winfal.log.

Solution



Temporarily, to correctly restore the EFS encrypted files, the EFS encrypted files need to be restored using other restore methods such as Web Based File Recovery (WBFR), Migrate Utility, Recovery Agent Namespace using Windows Explorer and Manage Content from Altiris Console.

To resolve this issue in future cases, the resolution is in the form of NDMFALS.dll which needs to be applied to the client computer with Recovery Solution Agent installed. NDMFALS.dll is included in the Client.zip uploaded attached to the right:

  1. Stop the Recovery Solution Agent service on the client computer.
  2. Browse to %Program Files%\Altiris\eXpress\Client Recovery Agent.
  3. Download the NDMFALS.dll from Client.zip (attached to the right).
  4. Replace the old NDMFALS.dll with the new NDMFALS.dll from Client.zip from attachments.
  5. Restart the Recovery Solution Agent service on the client computer.
  6. This computer may now start new snapshots that will support EFS. Note: Do not use roll back dates for this client which are prior to implimenting this hotfix or step 4 will be undone and the hotfix will need to be reapplied.
  7. For these new snapshots which will support EFS, you may create the Full System Recovery (FSR) MiniOS media from the Altiris Console.

NDMFALS.dll also needs to be updated to the Data1.cab. The Data1.cab needs to be updated so that new Recovery Agent installations will have the hotfix. It can be modified using ASPack.exe utility. More about ASPack.exe is available in article 24583.


Attachments

Client.zip (75 kBytes)

Legacy ID



34761


Article URL http://www.symantec.com/docs/TECH29579


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