Error "'Unauthorized Request' in Performance Monitor/ '401: Unauthorized" when resetting agent

Article:TECH31188  |  Created: 2007-06-15  |  Updated: 2008-01-23  |  Article URL http://www.symantec.com/docs/TECH31188
Article Type
Technical Solution


Issue



When trying run Monitor Solution's Performance Monitor against any computer with the Monitor Agent installed, I receive the error, "The Altiris Monitor Agent refused the connection. Unauthorized request."

Unauthorized request


When choosing the option Reset Agent from the Monitor Solution Dashboard, I receive the error "Server Error in '/Altiris/AeXMonitor' Application. The request failed with HTTP status 401: Unauthorized."

     Server error


Environment



Monitor Solution 6.0

Cause



Both of these errors are caused by inadequate permissions in the AeXMonitor folder in either IIS and/or the access list on the file system.

Solution



IIS

  1. On the Notification Server, open Internet Information Services (IIS) Manager and go to the folder Web Sites > Default Web Site > Altiris > AeXMonitor.
  2. Right-click on the Agent folder and click Properties.
  3. On the Directory Security tab under Authentication and access control, choose Edit.
  4. Make sure both Enable anonymous access and Integrated Windows authentication are enabled


File System

Note: Computers running the Monitor Agent must have access to the '..\AeXMonitor\Agent' folder on the Notification Server. Access to this folder is done using the computer's Local System acocunt.

  1. On the Notification Server, browse to <installation path>Altiris\Monitor Solution\AeXMonitor.
  2. Right-click on the Agent folder and click Properties.
  3. On the Security tab, make sure that either the Users or Authenticated Users group is listed and has Read and Execute permissions.
     

Security Policy

Ensure that the Guests security group does not have any customized restrictive / deny security policy settings. For example, if Guests has been configured for Deny access to this computer from the network, it will cause this behavior.


Legacy ID



35523


Article URL http://www.symantec.com/docs/TECH31188


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