Local backup or restore with Backup Exec 11d and above to 2010 may fail with the error: "Remote Agent not detected on Server name" and "a000846a: Device could not be restored because an error occurred while connecting to the Remote Agent for Windows Servers. Make sure that the Remote Agent for Windows Servers is running on the target computer."

Article:TECH31556  |  Created: 2004-01-12  |  Updated: 2012-03-07  |  Article URL http://www.symantec.com/docs/TECH31556
Article Type
Technical Solution

Product(s)

Problem



Local backup or restore with Backup Exec 11d and above to 2010 may fail with the error: "Remote Agent not detected on Server name" and "a000846a: Device could not be restored because an error occurred while connecting to the Remote Agent for Windows Servers. Make sure that the Remote Agent for Windows Servers is running on the target computer."


Error



"Final Error Code : a000846a HEX Device could not be restored because an error occurred while connecting to Remote Agent for Windows Servers. Make sure that Remote Agent for Windows Servers is running on the target system."

The Backup Exec Job Engine service debug log may show the following error:
 

468 2/17/2004 10:36:13: ERROR: unknown host: SERVERNAME, err=11004
 

468 2/17/2004 10:36:13: SetupNDMPConnection: ndmpConnect failed on server SERVERNAME, port: 10000.
 
468 2/17/2004 10:36:13: NDMPEngine::Run(): SetupNDMPConnection() returned -472, falling back to local RANT (as specified) to perform operation.
 
468 2/17/2004 10:36:13: ERROR: unknown host: SERVERNAME, err=11004
 
468 2/17/2004 10:36:13: SetupNDMPConnection: ndmpConnect failed on server SERVERNAME, port: 10000.
    
*See Related Documents for putting the Job Engine into debug mode.

 Final error: 0xe000846b - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent. 

Make sure that the correct version of the Remote Agent is installed and running on the target computer.

Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-33899

 


Cause



The local machine is not physically connected to the network. 


Solution



Although local backup selections are made, Backup Exec treats the backup operation like a remote backup because it must go through the remote agent.
 
When communication takes place between Backup Exec and the Remote Agent for Windows Servers during a backup or restore operation, a control connection is first established. Backup Exec first attempts to connect to the remote agent via the Network Data Management Protocol (NDMP) port. The remote agent will then respond back to Backup Exec with a port specified in the Enable media server TCP dynamic port range option. (The port range can be found by looking in Tools | Options | Network). The control connection is responsible for any traffic that is not related to the data stream (what resources to back up, credentials to login to the resources, selection lists).
 
Once the control connection has been established, a second connection is then established between the remote agent and Backup Exec. This is called the Data connection. If there are multiple resources being backed up then there will be multiple data connections, one for each resource. Backup Exec first binds itself to a port specified in the Enable media server TCP dynamic port range option. (Port Range can be found by looking in Tools | Options | Network). It will then attempt to attach to the remote agent using a port specified in the Enable remote agent TCP dynamic port range option. Once this connection is established, data will be sent over it for the backup/restore operation.
 
After each session is finished, the ports are left open for 60 seconds, making sure there is no activity on them.
 
An example of how Backup Exec communication takes place is given below. It is using the default ports of 1025-65000 (Figure 1).
 

Figure 1
 


There are two ways to resolve this:

1.  Physically connect the machine to the network

or

2.  Install the Microsoft Loopback adapter

To install the Microsoft Loopback adapter, use the following steps:

*These steps are specific to Windows 2003.

 
1. Go to Start | Settings | Control Panel | Add/Remove Hardware
 
2. Click Next. Select Add/Troubleshoot a device, and then click Next.
 
3. The Add/Remove Hardware Wizard displays a list of devices that are installed on the machine. Select Add a new device, and then click Next.
 
4. Select No, I want to select hardware from a list, and then click Next
 
5. From the Hardware Types window, select Network Adapters, and then click Next
 
6. From the Select Network Adapters window, under Manufacturer, select Microsoft and under Network Adapters, select Microsoft Loopback Adapter, and then click Next
 
7. Continue by following the on-screen instructions
 

Supplemental Materials

SourceError Code
Valuea000846a
Description

  "Final Error Code : a000846a HEX Device could not be restored because an error occurred while connecting to Remote Agent for Windows Servers. Make sure that Remote Agent for Windows Servers is running on the target system."


SourceError Code
Value0xe000846b
Description
Final error: 0xe000846b - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent. 
Make sure that the correct version of the Remote Agent is installed and running on the target computer.
Final error category: Resource Errors

SourceUMI
ValueV-79-57344-33899


Legacy ID



267345


Article URL http://www.symantec.com/docs/TECH31556


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