Microsoft Exchange Server Individual Public Folder restore job fails with the error "Access is denied" or "Cannot restore properties for one or more messages or folders"

Article:TECH31876  |  Created: 2004-01-28  |  Updated: 2013-11-08  |  Article URL http://www.symantec.com/docs/TECH31876
Article Type
Technical Solution

Product(s)

Issue



When Backup Exec for Windows Servers is correctly configured to back up individual Microsoft Exchange Mailboxes/Public Folders and the mailbox/ public folder backup jobs are successful. However, when performing a restore of the public folders back to their original location, the public folder restore job fails with the error: "Access is denied" or "Cannot restore properties for one or more messages or folders".
 

Note: For details on the correct configuration of Backup Exec for Microsoft Exchange Mailbox and Public Folder backups, see the "Related Documents" section at the end of this document.


Error



Microsoft Exchange Server Individual Public Folder restore job fails with the error "Access is denied" or "Cannot restore properties for one or more messages or folders"


Cause



The above error can occur during restores of individual Microsoft Exchange Public Folders if the Backup Exec Service Account that is specified for the individual Microsoft Exchange Public Folders backup jobs is not configured in Outlook with the "Owner Role."  
 
Note: Though it is possible to back up individual Microsoft Exchange Public Folders without granting the account (that is specified for the individual Microsoft Exchange Public Folders backup jobs) the "Owner Role" in Outlook, the "Owner Role" is required for the account used to perform Public Folder restores.


Solution



 Determine what account was used to perform the successful individual Microsoft Exchange Public Folders backup job.  Next, grant this account the "Owner Role" through the Microsoft Outlook client while logged on to Outlook with an account that already has the "Owner Role" on the Public Folders to be restored.

1. To determine what account was used to perform the successful backup of the individual Microsoft Exchange Public Folders:

a. Open the Backup Exec user Interface to the "Job Setup" screen and double-click on the Public Folder Backup job
b. From the "Task" pane of the "Backup Job Properties" dialog box, click on Selections | Resource Credentials
c. The account used for the public folder will be listed in the right pane under the column "Logon Account".
 
2. To grant the above "Logon Account" the "Owner Role" in Outlook:

a. Open Outlook with the Administrator-level account used to manage Microsoft Exchange Public Folders.
b. Expand "Public Folders" and highlight the public folder that needs to be configured (Figure 1)

Figure 1
 

c. Right-click on the Public Folder and select the Properties | Permissions tab (Figure 2)

Figure 2
 

d. Highlight the account that was used to perform the successful backup of the individual Microsoft Exchange Public Folders in the top pane.
e. Under Permissions, use the Roles drop-down box to select the "Owner" role (Figure 2) and click OK.


Once the above steps have been performed, run the Public Folder restore job again.

Also make sure Administrative Rights are not automatically applied to Public Folder subfolders.
When you configure administrative rights to propagate from a public folder to all its sub-folders, the administrative rights that you have configured are not inherited by new sub-folders that you create.
 http://support.microsoft.com/kb/815916

 

 


Supplemental Materials

SourceUMI
ValueV-79-57344-765
Description

Cannot restore properties for one or more messages or folders


SourceError Code
Valuee000848c
Description

Access is denied



Legacy ID



267764


Article URL http://www.symantec.com/docs/TECH31876


Terms of use for this information are found in Legal Notices