KNOWN ISSUE: Software Portal hangs—there is a Viewstate error in the Server log file when a request is made
| Article:TECH33773 | | | Created: 2007-08-22 | | | Updated: 2008-08-14 | | | Article URL http://www.symantec.com/docs/TECH33773 |
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Problem
When a request is made from the Software Portal, it hangs and errors out. The following errors are recorded in the Server log file:
Priority: 1
Date: 07/24/2007 2:18:12 PM
Tick Count: 745041250
Host Name: NSSERVER
Process: w3wp.exe (7208)
Thread ID: 2284
Module: AltirisNativeHelper.dll
Source: global.asax
Description: Unhandled exception. Type=System.Web.HttpException Msg=Invalid_Viewstate_Client_Disconnected
Client IP: 10.169.200.54
Port: 2461
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; STIE60-021004; STIE60-020212; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1)
ViewState: Very log string of numbers
Http-Referer: http://<NSFQDN>/Altiris/SWD/SWDWin32/SWPortal/Portal/TreeView.aspx?MachineGuid=<GUID>&MachineName=REQUESTOR&Platform=Win32&MaxAllowedRequests=5
Path: /Altiris/SWD/SWDWin32/SWPortal/Portal/TreeView.aspx.
StackTrace=
at System.Web.UI.Page.LoadPageStateFromPersistenceMedium()
at System.Web.UI.Page.LoadPageViewState()
at System.Web.UI.Page.ProcessRequestMain()
Inner exception. Type=System.FormatException Msg=Invalid length for a Base-64 char array.
Priority: 1
Date: 07/24/2007 2:33:06 PM
Tick Count: 745935296
Host Name: NSSERVER
Process: w3wp.exe (7208)
Thread ID: 5716
Module: AltirisNativeHelper.dll
Source: global.asax
Description: Unhandled exception. Type=System.InvalidOperationException Msg=Request format is unrecognized.
StackTrace=
at System.Web.Services.Protocols.WebServiceHandlerFactory.CoreGetHandler(Type type, HttpContext context, HttpRequest request, HttpResponse response)
at System.Web.Services.Protocols.WebServiceHandlerFactory.GetHandler(HttpContext context, String verb, String url, String filePath)
at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, String path, String pathTranslated, Boolean useAppConfig)
at System.Web.MapHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)We've also seen other synptoms such as a hanged portal, page cannot be found, timeouts, and others that this hotfix has resolved.
Environment
Notification Server 6.0 SP3 R4
Software Delivery Solution 6.1 SP2 SP3
Cause
The number of objects in the Software Portal under certain stressed environments can cause this error. Replication of this error took considerably more items in a testing environment than what customers have seen. This is a defect in the buffer used to enumerate the portal objects.
Solution
The hotfix that resolves this issue is available. It can be downloaded by clicking on the link in the right-side pane. To apply, simply execute on the Notification Server system.
Attachments
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| Source | DEFECT |
| Value | LB 61129 |
| Description | Logged in Littlebuggy (Altiris - Lindon, Plymouth) database |
Legacy ID
37620
Article URL http://www.symantec.com/docs/TECH33773
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