Hotfix 4: Storage Inaccessible and Data File Synchronization Job errors

Article:TECH36063  |  Created: 2007-10-15  |  Updated: 2007-10-15  |  Article URL http://www.symantec.com/docs/TECH36063
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Article Type
Technical Solution

Issue



During snapshots, server jobs fail due to Storage is inaccessible to the Recovery Solution Server. The following event appears in the application event:

The data storage location 'F:\Altiris\DataStorage' is offline and not accessible now.
Local Event Code: 0x8008000f
System Event Code: 0x00000020: The process cannot access the file because it is being used by another process.
SbsName:  , SbsKey: 0, 0

Data File Synchronization job for Synchronous Storage completes with errors.


Environment



Recovery Solution 6.2.2760 (SP2)
EMC CLARiiON SAN Storage*
Synchronous Storage

Cause



It is a physical (timing) problem on the storage.

Definition of the disk latency in a SAN environment is a very difficult task, because there are many physical and logical nodes: operating system, physical disks, RAID, one or more HBAs, one or more fibers (HBA > SAN), ports on SAN, may be fiber-switch, and so on.

Solution



This hotfix is in the form of DSRawData.dll and GetUnsyncFileBlocks.sql.

DSRawdata.dll needs to be applied to the Recovery Solution Server. DSRawData.dll is uploaded to Server.zip in attachments:

  1. Stop the Recovery Solution Server service.
  2. Browse to the %Program Files%\Altiris\Recovery Solution\Server folder.
  3. Replace the old DSRawdata.dll with the new one uploaded to dsrawdata.zip in attachments.

The GetUnsyncFileBlocks.sql Stored Procedure needs to be updated to the Recovery Solution Database:

  1. Open SQL Query Analyzer by clicking Start > Programs > Microsoft SQL Server > Query Analyzer.
  2. Download GetUnsyncFileBlocks.sql from Server.zip in attachments
  3. Load the stored procedure on to the SQL Query Analyzer.
  4. Select the Recovery Solution Database from the drop-down list and execute the Stored Procedure.

Restart the Recovery Solution Server service.


Attachments

Server.zip (605 kBytes)

Legacy ID



38762


Article URL http://www.symantec.com/docs/TECH36063


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