Disk groups created on iSCSI storage do not auto import in Veritas Storage Foundation for Windows
| Article:TECH36108 | | | Created: 2004-01-13 | | | Updated: 2011-12-07 | | | Article URL http://www.symantec.com/docs/TECH36108 |
Problem
Disk groups created on iSCSI storage do not auto import in Veritas Storage Foundation for Windows
Error
vxboot: Failed to auto-import disk group [disk group]. All volumes in the disk group are not available
Cause
This behavior occurs because iSCSI storage is not available to the operating system at the time that Windows is booting. iSCSI storage is not available until the Microsoft iSCSI Initiator service (MSiSCSI) has started.
Solution
Use the Delayed Import Service to make Storage Foundation wait until after the MSiSCSI service has started before attempting to import the disk group. This will allow the disk group to automatically be imported after Windows has finished booting.
Note: It may be necessary to add an additional dependency on another service, such as the NETLOGON or Server service to successfully use the Veritas DG Delayed Import Service with iSCSI disks
Follow these steps to resolve the issue:
1. Set the Veritas DG Delayed Import Service to be dependent on the Microsoft iSCSI Initiator service. This can be done by following this Microsoft Knowledge Base article: http://support.microsoft.com/kb/193888.
2. From a Windows command prompt, type the following:
vxdg -g [disk group] latestart on
Note: Replace "[disk group]" with the name of the disk group that contains the disks that reside on the iSCSI array.
To disable the late start functionality for a disk group, use the following command:
vxdg -g [disk group] latestart off
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Legacy ID
273694
Article URL http://www.symantec.com/docs/TECH36108
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