The Helpdesk Knowledge Base will not configure

Article:TECH36496  |  Created: 2007-10-26  |  Updated: 2011-07-14  |  Article URL http://www.symantec.com/docs/TECH36496
Article Type
Technical Solution

Issue



The Helpdesk Knowledge Base will not configure.
After trying to apply the Knowledge Base configuration settings, the page reports back
"The Knowledge Base configuration was unsuccessful.  Please contact your system administrator."

Altiris Logs with a source of “Altiris.KnowledgeBase.Services.Configuration.SetKBConfig”
First one log entry will have the  description “Begin database setup“ followed by a log with the description “Finish database setup :retVal: False” telling that the database update had failed.


Environment



Helpdesk 6.0.297

Cause



The Knowledge Base Configuration was missing the SQL file needed to update the database, specifically “\Altiris\Knowledge Base\KBDatabase.sql”

Solution



Do a repair of Alert Manager to restore the missing file(s).
To repair Alert Manager, right mouse click on the msi "c:\Program Files\Altiris\Setup Files\Altiris Helpdesk\AlertManager.msi" and select repair.
Once the repair has finished, try the Knowledge Base Configuration page again.

Legacy ID



38973


Article URL http://www.symantec.com/docs/TECH36496


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