Task Server Error 'An exception occurred while attempting to process status post'
| Article:TECH36503 | | | Created: 2007-10-26 | | | Updated: 2007-10-26 | | | Article URL http://www.symantec.com/docs/TECH36503 |
Problem
Tasks are either not received by client, or are not reporting back successfully. The Log Viewer shows the following error:
Priority: 1
Date: 10/15/2007 9:52:25 AM
Tick Count: 1548062
Host Name:
Process: w3wp.exe (2712)
Thread ID: 5472
Module: AltirisNativeHelper.dll
Source: Altiris.ClientTask.*
Description: An exception occurred while attempting to process status post. Error: System.Exception: An exception occurred while executing the request ---> System.Exception: System.InvalidOperationException: Process performance counter is disabled, so the requested operation cannot be performed.
at System.Diagnostics.NtProcessManager.GetProcessInfos(PerformanceCounterLib library)
at System.Diagnostics.NtProcessManager.GetProcessInfos(StringmachineName, Boolean isRemoteMachine)
at System.Diagnostics.ProcessManager.GetProcessInfos(StringmachineName)
at System.Diagnostics.Process.EnsureState(State state)
at System.Diagnostics.Process.get_WorkingSet()
at Altiris.ClientTask.Server.ClientTaskServer.ProcessPostClientStatus(Hashtable input, Hashtable& output)
at Altiris.Core.Sockets.SecureRemoting.SecureRemotingServer.ProcessRequestObject(Object work)
--- End of inner exception stack trace ---
at Altiris.Core.Sockets.SecureRemoting.SecureRemotingClient.SendRequestI(String service, Hashtable input)
at Altiris.Core.Sockets.SecureRemoting.SecureRemotingClient.SendRequest(String service, Hashtable input)
at Altiris.ClientTask.Server.Web.WebClientApiManager.ProcessPostClientStatus(NameValueCollection queryValues, Stream requestStream, Int32
contentLength)
Environment
NS 6.0.6074 SP3 (R5)
Task Server 6.0.1356
Cause
Corrupt Microsoft profiler files.
Solution
Altiris uses the Performance Counters supplied by Microsoft in our processes. It is possible that one of the files has become corrupt. The following Microsoft article provides the steps to manually rebuild the Performance Counter files.
http://support.microsoft.com/default.aspx?kbid=300956
Please followed the steps in the document to resolve the issue
Legacy ID
38975
Article URL http://www.symantec.com/docs/TECH36503
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