KNOWN ISSUE:"Unknown error processing summary row" message in agent logs indicating the Altiris Agent has crashed

Article:TECH36556  |  Created: 2007-10-29  |  Updated: 2007-12-03  |  Article URL http://www.symantec.com/docs/TECH36556
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Issue



The Altiris Agent terminates unexpectedly on client computers with Application Metering Agent installed. Agent logs contain the errors below:

 <![CDATA[Unknown error processing summary row. Data is: xxx xxx xxx]]>

 <![CDATA[Unknown exception]]>

 <![CDATA[Unexpected exit C0000005]]>


Environment



Application Metering Agent 6.1.31


Cause



This issue will occur when an executable contains a blank "space" in the header data for Internal Name. The Application Metering agent will terminate when constructing the Summary Data and records the error message in the agent.log file.

To verify a problem executable:

  1. Locate the error in the Agent.log file.
  2. Find the specific executable listed in the error text.
  3. Locate the applicable executable on the client computer.
  4. In Windows, right-click on the file, and click Properties.
  5. Choose the Version tab and verify the Other Version Information.
  6. Check each property, to verify its attribute.

Solution



This issue has been resolved in a hotfix .dll available for the Application Metering Sub-Agent.   Please refer to KB Article 48204 to download the replacement file.


Supplemental Materials

SourceDEFECT
ValueLB 62572
DescriptionLogged in Littlebuggy (Altiris - Lindon, Plymouth) database

Legacy ID



38995


Article URL http://www.symantec.com/docs/TECH36556


Terms of use for this information are found in Legal Notices